vexnet 2.0 used to work before new key

my team has been using the 2.0 keys since they came out last year and have not had a problem until the one in the cortex bent. because it is bent, the connection is not very reliable with that key. we got a new one recently and tried replacing the bent key with the new key. after replacing and A-A cabling, they didnt want to communicate at all. since then, we have tried upgrades to the joystick, cortex and both keys using downloads from here.

as well as most recent firmware from robotc (before the stuff from vex).

what elts should i try?
why cant i do all the cortex and joystick updates strictly through robotc?

what am i missing?

thanks so much!

-974X Cyberbrains


when the new key is in the cortex and the unbent key in the joystick, the joystick is all green and the cortex is flashing double reds.

when the new key is in the joystick and the unbent in the cortex, they have no communication. and the vortex keeps on re-setting.

with the bent and unbent key in either orientation the communication is there but because one is bent is inconsistent.

hope this helps.

is it possible we have a bad key?


974X Cyberbrains

Cyber brains,

Thanks for your detailed post. I suspect you need to upgrade the firmware in your system to match that of the new VEXnet Key 2.0

Did you already tried to upgrade the firmware on the Microcontroller & Joystick?
If so, can you attach a screenshot of the firmware program you are using?

Because ROBOTC is still working on an update that will be 100% compatible with the VEXnet Keys 2.0

I’m very confident you do not have a bad VEXnet Key.


thanks eli

we used a different computer to try to update the keys, joystick and controller and it FINALY worked. we are going to re format our laptop and get the 4.x version of robotc and hope that this doesn’t happen again.

again, thanks for your time.