VEXnet Competition Switch not Switching Modes

My adviser for my robotics club bought us VEXnet Competition Switches to help us practice our autonomous program. The switch was brand new and when we attempted to switch from driver disabled to autonomous disabled the switch would still allow us to drive. When we enabled autonomous it would still allow us to drive and the program would not run.

Essentially, the switch is stuck on driver control enabled and wont switch out of it. This is for VEX EDR and im using robotC.

Other competition switches work fine with our robot and controller, but not this one.

Are you sure you plugged it in? :stuck_out_tongue:

Seriously though, there doesn’t seem to be anything wrong with the joystick; it’s probably just a loose connection on the comp switch. From your description of the problem, it seems like the problem is with ground/common. Unless hitting it really hard works (I fixed an encoder like that once), you should probably just return it and get a new one.

It is for sure plugged in on both ends. I have tried different connectors and many other things and it will not switch modes. I have tried it on different robots and cortexes and it has not worked. I cannot really return it because it was through my school and I desperately need it to help me program my PID loop because i am able disable the robot as it runs. :confused:

Well, since you’re using RobotC, there’s a virtual competition switch built into the UI.
As long as you have the programming cable connected and VEXnet active (which you surely do while tuning the PID), you can switch the modes from your computer.
Just go through menus, you should find it (my students did). The control window has 3 buttons - disable, auton a and teleop, so you can quickly disable the robot as you need.

You’ll need to debug the whole control system chain to be sure, but when my team had this issue it turned out to be our joystick. We have no idea what caused it to this day, and there didn’t appear to be any physical damage, but it was the joystick for certain. You may want to check on that.

It has the same issue for every other robot and controller. I’ve tried about 8 other teams controllers and they all were stuck on driver mode. I tried switching the cord that connects them and it did not fix it.

Call VEX support.

Driver mode is just the default mode. Doesn’t seem like it works at all. Try to find another team with a switch for troubleshooting.