VEXnet connection issues

Our VEXnet 2.0 keys are not pairing. VEXnet is up-to-date (4.23), Cortex and Joystick are up-to-date, we are running RobotC 4.27. The cortex and joy stick pair fine, but when the VEXnet keys are added, both the cortex and joystick have double red blinking lights on VEXnet and Game. When searching the forum, I found another group that was having similar issues and they solved it with a VEXnet update. We just tried that, and everything was already up-to-date. The user guide refers to an invalid ID, but I was unable to figure out what that means or how to fix it.

I am using the joysticks for both my HS class, as well as my MS competition teams.

To confirm, are you using the VEXNet 1.0 keys (black keys) or the VEXNet 2.0 keys (white keys)? If you are using the VEXNet 2.0 keys, have you updated the firmware version on the keys themselves to version 1.46, using the latest VEXNet 2.0 Key Upgrade Utility (http://www.vexrobotics.com/wiki/Software_Downloads#2_-_Update_Firmware_on_Cortex_Microcontroller.2C_VEXnet_Joystick.2C_and_VEXnet_Key_2.0)?

Instructions on this process can be found in step 5 of our Getting Started with VEX Cortex - Wireless guide (the process should be the same no matter what programming language you are using).

Getting Started with VEX Cortex - Wireless: [http://help.robotc.net/WebHelpVEX/index.htm#Topics/Getting%20Started/Getting%20Started%20-%20Cortex%20VEXNet.htm%3FTocPath%3DGetting%20Started%20-%20Physical%20Robots|_____3

Please let us know if this resolves the issue for you.](http://help.robotc.net/WebHelpVEX/index.htm#Topics/Getting%20Started/Getting%20Started%20-%20Cortex%20VEXNet.htm%3FTocPath%3DGetting%20Started%20-%20Physical%20Robots|_____3)

Yes, we are using the VEXnet 2.0, white, keys. I tried to attach a document with screen shots of everything being up-to-date, but am unable to do so in the forum for some reason.

VEXnet Upgrade Utility V4.1.5, updating to version 4.23, and firmware to both the cortex and joystick.

I’ve paired the cortex and joystick with the usb, but when the VEXnet keys are attached I get the double red blinking lights on the VEXnet and Game lights on both the cortex and joystick. The VEXnet blue light is solid on the cortex and blinking on the joystick when this happens. I’ve tried with numerous sets of VEXnet keys (2.0, new this year) with the same result.

This is for the VEXNet Firmware Update Utility; have you run the separate VEXNet 2.0 Key Upgrade Utility with the VEXNet 2.0 keys plugged into the computer directly, one at a time? The new VEXNet 2.0 keys have firmware chips in the USB keys themselves, and they will need to be updated to the latest version in order to ensure compatibility with the newest Cortex and Joystick firmware versions.

The Cortex and VEXNet Joystick firmware versions are on 4.23 currently; the VEXNet 2.0 Key firmware versions are on version 1.46.

I apologize in advance if this has already been done, it was not 100% clear from the previous post and I don’t want to assume that this step has not been skipped.

Thank you for clarification regarding the VEXnet KEY utility. That seems to have taken care of the problem. My competition teams will be excited to be able to test their programs this evening.

So many updates…Thank you!