VEXnet Failure

I didn’t know if this pertained to ROBOTC, so I am putting this in the General Forum also.

This is my first time connecting a Cortex and VEXnet Joystick remote. I have followed what this guide says: http://www.education.rec.ri.cmu.edu/products/teaching_robotc_cortex/reference/VEXnet_setup_guide.pdf

I connect the male to male usb ports to the Cortex and VEXnet Joystick remote, and I turn the cortex on. It then says to wait for the ROBOT, and VEXnet to blink green. Only the ROBOT blinks green. What do I have to do to get the VEXnet to blink green?

I just re downloaded the firmware for each item (Cortex and VEXnet Joystick).

Any help would be appreciated!

Edit: Here is a picture of the lights that are now working…
http://team323z.weebly.com/uploads/1/0/0/6/10062475/4123332_orig.jpg

just a quick thing … plug your tether cable into both controller and cortex, and only power the cortex, this should allow you to use your controller (s) … now if this works, we can rule out either the controller and cortex from being broken, if so the vexnet keys are broken, and you will need to get new ones … contact Vex … or the seller (if still in warranty), now if the tether didn’t work, you need to start from scratch, install all the firmware manually, on both devices, then download your program, if it doesn’t work again, contact vex official help

  • Reason i know about this, i had the same problem on a 6 month old cortex, and i ended up buying new keys, and it worked …

if problem still persists, contact vex tech team help

hope i helped

FYI: I just ordered the parts on Monday, so they are new.

I am redownloading the firmware on each device, then I will connect the male to male usb ends to the Cortex and VEXnet Joystick. Then I am going to power just the cortex with the usb ends in?

Yes … do that … plug in the joystick controller to the cortex, using the male a-a (tether cable) … then power the cortex

OK, that is done.

The ROBOT on the Cortex is flashing green slowly, and the VEXnet is just solid green.

The JOYSTICK on the VEXnet Joystick is red (because it is not on), the ROBOT is flashing green slowly, and the VEXnet is just Green.

What should be happening if I am doing this right? Or am I doing it right?

Yes that is good ! … do you have a program on the cortex, if not download a sample program on the robotc: try the dual control program … but if you already have a program downloaded, try the controls, if the controls aren’t working try re-downloading the program

And if this doesn’t work … send me your code ! … will see what is the problem

OK, I can download a program onto the Cortex now. When I turn on the Cortex, and I plug in a motor on the left 2 holes, it automatically starts spinning, very slowly. If I plug the 2 wire 393 motors into the 2 right spots on the cortex (there are 3 holes I can stick the motors into, which one do I stick it into?) it spins fast. Why is it spinning?

Here is my code (its the sample program)

#pragma config(Motor,  port2,           rightMotor,    tmotorVex393, openLoop)
#pragma config(Motor,  port3,           leftMotor,     tmotorVex393, openLoop)
//*!!Code automatically generated by 'ROBOTC' configuration wizard               !!*//

/*----------------------------------------------------------------------------------------------------*\
|*                                    - Dual Joystick Control -                                      *|
|*                                      ROBOTC on VEX 2.0 Cortex                                      *|
|*                                                                                                    *|
|*  This program uses both the Left and the Right joysticks to run the robot using "tank control".    *|
|*                                                                                                    *|
|*                                        ROBOT CONFIGURATION                                         *|
|*    NOTES:                                                                                          *|
|*    1)  Ch1 is the X axis and Ch2 is the Y axis for the RIGHT joystick.                             *|
|*    2)  Ch3 is the Y axis and Ch4 is the X axis for the LEFT joystick.                              *|
|*                                                                                                    *|
|*    MOTORS & SENSORS:                                                                               *|
|*    *              [Name]              [Type]              [Description]                   *|
|*    Motor - Port 2          rightMotor           VEX Motor           Right motor                    *|
|*    Motor - Port 3          leftMotor            VEX Motor           Left motor                     *|
\*----------------------------------------------------------------------------------------------------*/

//+++++++++++++++++++++++++++++++++++++++++++++| MAIN |+++++++++++++++++++++++++++++++++++++++++++++++
task main ()
{

  while(1 == 1)
  {
    motor[leftMotor]  = vexRT[Ch3];   // Left Joystick Y value
    motor[rightMotor] = vexRT[Ch2];   // Right Joystick Y value
  }

}
//++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

I downloaded this program with the orange programming cable, which is connected into the programming port on the VEXnet Joystick, and the Cortex and VEXnet Joystick are tethered together. The program does not work.

Help?*

Are you using the Motor Controller 29?
See attachment.

Your motor automatically spins because you are connecting the pins directly into the V+ output.

-Eli
Motor Set-Up.jpg

I just figured that out. No I am not using the Motor Controllers, so I will need those.

Thank you :smiley:

I still cannot get the Cortex and the VEXnet Joystick to connect using VEXnet.

How are you downloading? USB cable? Serial programming cable? What type of download have you selected, if it’s USB only then it will not look for the network and assume you are standalone, select “competition”, I find that’s the most appropriate.

I have it on USB right now. Will the VEXnet work with it on “competition”?

I try to download the program, and with “Competition” selected, this is what pops up:

http://www.weebly.com/uploads/1/0/0/6/10062475/3556782_orig.jpg

I do not think that the Cortex and VEXnet Joystick are connected over VEXnet yet… I am still not sure how to get that all connected…

Ok, I re-read you post from below.

So you have the following

cortex <----- USB A-A cable ------> Joystick <---- orange prog cable -----> PC

and can download. Thats good.

Try this test code, it’s basically your code but using ports 1 and 10 as you do not have MC29s.

#pragma config(Motor,  port1,           rightMotor,    tmotorVex393, openLoop)
#pragma config(Motor,  port10,           leftMotor,     tmotorVex393, openLoop)
//*!!Code automatically generated by 'ROBOTC' configuration wizard               !!*//

task main ()
{

  while(1 == 1)
  {
    motor[leftMotor]  = vexRT[Ch3];   // Left Joystick Y value
    motor[rightMotor] = vexRT[Ch2];   // Right Joystick Y value
  }

}
//++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Set the Vex communications mode to competition, download and start the program. Does it work ?

Now power off the cortex and joystick, insert the VEXnet keys, power on again, does it work?

If it does not, post the firmware versions (3.xx etc.) ROBOTC version (V3.xx) and ROBOTC firmware version (9.??). Can you do a software inspection from the Robot menu.

OK, I downloaded the code you game me to the Cortex/VEXnet Joystick, and it works while it is connected to each other with the USB.

I then plugged the VEXnet sticks into the Cortex and VEXnet joystick, and the program ran with the programming cable in (I don’t have a competition switch yet because they were out of stock). So theoretically, I should be able to download the program to the remote, then start the program with the competition switch?

Thank you for your help all!

Edit: I turned the Cortex and VEXnet Joystick off, and try to download the program again to run the motors, but then an error pops up like the picture I have up on one of my later posts. The VEXnet is flashing RED on the Cortex, and flashing YELLOW on the VEXnet Joystick. What did I do?! I can connect the USB to the Cortex and VEXnet joystick and the program runs fine. I still don’t think the VEXnet is connected…

Ok, well … it must be the vexnet keys, if you have paired the cortex and transmitter and the keys are still not working, it has 2 be the keys

Are they just not connected yet, or are they broke. I just got them on Thursday.

well,try connecting the a-a cable to both the transmitter and cortex again, but it if doesn’t work … it is your keys !

I’m not completely understanding your explanation here.

So initially everything was working, you could turn on the cortex and joystick with the VEXnet keys installed and the program I sent worked. Did you do this more than once or did it only work one time?

This does not make sense, you tried to download again with it all turned off?

or, did you try and download a new program with the VEXnet keys installed? Is that when everything stopped working?

So back to basics

Are your batteries good? I mean both the cortex battery and the joystick batteries.

Post all the firmware version numbers. Do you have the new style programming adapter? (just curious here if it is supported well in ROBOTC, I doubt it’s the issue)

Can pull up the software inspection with the USB A-A cable connected, is everything good in that window?

It most likely is a bad or intermittent VEXnet key but there is a small possibility it’s something else.

I am just getting used to ROBOTC, so I am not a pro.

Where do I fine the Firmware version numbers in ROBOTC? Yes, I have the new style programming adapter.

Where do I fine the Software Inspection Window? How do I know if it is good?

Sorry for now knowing a lot. This is my first time really working with ROBOTC.

I just found the Software inspection page. This is what it read:


Communications Link:               COM Port 'COM8' to VEXNET Joystick
                                   

Standard Firmware File Names:
=============================
VEXNET Joystick:                   .\Firmware\JOY_V3_21.BIN
VEX Cortex Master CPU Firmware:    .\Firmware\CORTEX_V3_21.BIN
VEX Cortex CPU Firmware:           .\Firmware\VEX_Cortex_0912.hex

VEXnet Joystick Integrity:
==========================
Firmware Version:                  3.21                    Up to Date
Battery Voltage:                   7.3V                    Good (>7.1V)
Calibrated:                                                No
Joystick State:                    Powering Up                        

Cortex Master CPU Integrity:       Value						       Status
============================
Firmware Version:                  3.21                    Up to Date
Main Battery:                      8.0V                    Good (>6.5V)
Backup Battery:                    0.0V                    Poor (<8.0V)
Team Name:                         "00ROBOTC"              Default. Not Assigned

Cortex User CPU Integrity:         Value						       Status
==========================
Firmware Version:                  9.12                    Up to Date
Program Type:                      VEXNET Wi-Fi (required)  Good