VEXnet Firmware Upgrade Utility Issues

BOTTOM LINE: If you’re having problems uploading the master code to your Cortex while using the utility.

UNPLUG AS MANY OTHER USB DEVICES AS YOU CAN!!!

I have a NC1 Cortex, Windows 7 x64, all of this on regular old USB 2.0 ports w/ a run of the mill A-A cable. Yes it’s an old Cortex model, not an excuse - you build it, you sell it, YOU SUPPORT IT.

I tried to update the firmware at least 30x times, failed every time, usually on the very first block (James believes that block 1-8 aren’t written to so block 9 is first). I unplugged all but my USB keyboard and mouse and the dang thing worked the very first time. In fact just to be sure I uploaded the master firmware again and it worked without issue.

Write this line as an instruction into the firmware upgrade utility manual: “blah blah blah, if NC1 or failing on block 9, unplug all other USB devices and try again, blah blah blah.”

Grr. -Cody

Glad you managed to get the firmware loaded.

This is just FYI background, the master firmware is stored as hex data and starts like this;

008000 D1 F1 B9 E6 1C F0 7E E2 10 F9 9F EE 14 78 91 F2
008010 18 D7 9E E4 01 E0 A3 E2 24 F0 1A E0 91 F6 89 E2
008020 87 80 26 00 41 82 E3 01 96 F6 02 02 7B 70 03 15
008030 98 DD 00 00 03 E2 00 00 45 81 01 01 C3 81 14 01
008040 33 FE D9 E9 FA FB 1A ED F6 F6 FB E1 D8 8D 91 F6
008050 AA 37 A1 E2 50 C4 A3 E0 24 35 A5 E6 2D 37 92 E2
008060 6F 31 B6 E5 41 36 F4 E3 FE FD FB 08 02 BE A3 F2

Notice the data starts at hex address 0x8000

This is from the LPC24XX user manual.
[ATTACH]8164[/ATTACH]

Address 0x8000 corresponds to sector 8, this is why I assume sectors 0 through 7 are skipped.

The master firmware ends at address 0x33EDF, so it looks like sectors 8 through 13 are used.
lpc24xx_flash.jpg

Hi Cody,
I met you at the event at the event at CU Boulder I believe.

I have never had an issue with this. I had a cortex plugged in, (I tried it with 3 or 4 different cortexes (or is it cortecies???), running the upgrade utility through both PROS and the ifi download off of a usb stick with 2 usb sticks, a usb mouse, keyboard and an external harddrive with no problems? try reinstalling the utility, or resetting the firmware first on a different computer adn then on yours.

Good old device manager showed some troblesome configurations in my experience. Since you are past your download issues it may be hard to reproduce.

The darn yellow warning triangle meant I could not see the cortex in the firmware manager. Once I wacked that yellow triagle it was relatively smooth sailing.

See:
https://vexforum.com/t/vexnet-2-0-upgrade-hints/25225/1

Or you too can spend a quality hour with Eli on tech support! (Multiply this by 5000 Vex teams, and yikes! That’s a lot of hand holding required.)

I remember having an issue with this when I helped a few schools update the older version of the Cortex. I had played with all the drives and devices… and it took me a while to finally update one. It kept getting hung at some point.

Thanks James, also thanks for all the help :slight_smile:

I don’t think it was me, I haven’t been to a VEX event this year, nor Boulder.

If I had to guess I’d say this is an issue specific to the NC1 Cortex. My joysticks all updated fine with my regular I/O plugged in. I don’t know what is different about the early Cortex model but obviously something is.

That sounds like you didn’t have the correct driver installed. Believe me I went through this too, but I was able to figure it out on my own.

This is exactly what I had going on but worse (probably due to the number of USB devices I had plugged in). This also confirms my suspicion that the issue is limited to the NC1 (the flat ones). Thanks!