VEXnet Key blues

So, we just got our Cortex and Controller in, but they will not connect. After doing some troubleshooting, we realized we had to update our keys with the VEX firmware. But when trying to run the setup thing that we got from the VEX website, it said “SetupCopyOEMInf() call failed - code - 536870353”. We have look at the forum and other resources, but are truly stumped. I would really appreciate if someone could tell us what to do.

BTW we are running windows 10

Try updating robotC? I’ve never heard of anything like that.

We have the latest version, and have updated the cortex and controller.

Have a look at these threads with similar issues:

Otherwise I’m not sure. Might be a question for official support.

Ignore that error. Run the VEXnet update utility, plug in the VEXnet key and see if it is detected. The most recent version of the firmware for VEXnet keys is 1.46, the utility will update your key if it needs it.

I think this is another driver signing issue, but it seems windows 10 will detect the key as a USB CDC device (ie. a serial port) and install a driver automatically for it. Let us know what happens.

You see, that’s the issue. My computer won’t run the VEXnet upgrade utility.

I’m having the exact same issue as the guy in the 2nd link. Maybe I should use a win 7 computer?

Ok, I had tried last night on Windows 10, had the same error from the setup program but the utility still worked, I could see the VEXnet key showing as a port in device manager. Have a look at this (the windows 8 section), perhaps turn off secure boot, install again and see what happens. (Turn on secure boot again afterwards)

Ok I’m not sure what the heck happened, but it works perfectly now without using the VEXnet key update thing. Thanks to everyone who has helped us figure this out. :slight_smile: