VexNet key making joystick venet light blink red

When plugged into the joystick, the 2.0 key causs the “venet” light to flash red. The joystick is up to date, as is the vexnet key and the cortex. The key causes the same thing to happen on the cortex. The joystick still controls the robot, and both work, but the vexnet light stays red. The lights change color only on whatever the key is plugged into. Please help!

Hello nxtmonkeys,

Thanks for taking the time to visit our forum.
Just to clarify, the robot still works in wireless even if the VEXnet LED is red… Correct?

If so, is the problem alleviated if you sue a different pair of VEXnet Keys?

I await your confirmation.


Yes, the robot still works in wireless when the vexnet light is red. I’ve noticed that when the joystick is close (about 1 to 6 inches) to the microcontroller, all lights are green, but once it is farther away (more than 6 inches), the vexnet light turns red again.
We tried a new pair of keys, and the problem was solved.
Thank you!