VEXNet Set-Up: USB Tether Does not Go GREEN

We seem to be having some issues with the set up of our first VEXNet upgrade. This is the blow-by-blow description of our most recent attempt to do the upgrade… we started over from the beginning after going through similar steps several times.

Step 1:

We downloaded Master Code V.8 wifi edition. “VEX_WIFI_MASTER_V8”
We received the message “Download Complete. Now reload user code.”
We downloaded the wifi Default Code. “VEX_WIFI_DEFAULT_FIRMWARE.hex”
When we restart the RC we get “IFI>Vex - Master v8, User v1”

We power everything down.

We connect the RX unit to the RC.
We connect the TX unit to the RX unit with the USB cable

We activate VEXNET by turning on the power on the back of the TX. Both “Robot” LEDs flash Green at about 1 Hz. We wait for over a minute… the LEDs are still blinking green. We have yet to achieve a “solid” green, and have tried this several times with 2 different USB cables.

We try turning on the TX front panel switch (it shows 10.1V) and we turn on the RC. BATT POWER is flashing green on the RC very quickly, but still no SOLID GREEN on the VEXNet components.

We turn everything off and try again. This time we turn on the RC first. That activates VEXNet… no change. We try again this time we turn on the TX (of course nothing happens) then we turn on the VEXNet TX switch. Same outcome… slow blinking green on both TX and RX vexnet “Robot” LEDs.

Step 2:

We have access to two VEXNet upgrade units, so we replace the original Receiver unit and attach the second unit to the RC.

We reactivate the system… now we get the same LED pattern on the VEXNet TX unit, but on the new RX unit we get the “VEXNET” LED flashing yellow rapidly for several seconds, followed by a pause, a blink, another pause, another blink and then ALL THREE LEDs on the RX unit. At this time all three LEDs on the TX unit also blink red.

We had this patter on the original RX unit, but it switched to the “1Hz Green Blink” reported above after one of our tethering attempts.

From my understanding, until we receive a solid green LED on both TX and RX during the tethering process we have not successfully paired the units. Earlier, after receiving results similar to those reported in Step 1 we tried with the dongles, but continued to receive 1HZ green “Robot” LED on both TX and RX, but got no response when moving the controls. We were also unable to program or receive data (the IFI> prompt) over the serial port on the transmitter.

Have we missed something…? Any suggestions?



I am not an expert but I think this is a mistake. I think “default” code is what you use if you don’t program and just want the joysticks to drive the robot.

Here is what we did for VEXNet and RobotC

We were able to install VEXNet and get Autonomous and Driver control to work last night.

We installed the VEX WiFi Master Code Ver 8 from here:

We then downloaded and installed Vex Competition Includes.c and the Vex Competition Template.c into ROBOTC v 1.7 from this thread:


We then updated VEX User Code firmware with the latest version found in ROBOTC v 1.7.

Next we added our autonomous and driver control to the new competition template and downloaded it to the robot.

Next we turned the VEX off and on.

We installed the cable from the Vex Competition switch.

Using the competion switch toggle between autonomous & operator control mode and enable/disable the modes.

We did find that you had to run autonomous (at least for a short time) to run driver control.

Jon T

Thank you for your replies. I believe you are correct that the default code is for driving with the joysticks. We intentionally downloaded that in order to test the communication between the TX and RX using “known good” software.

The students have written their own software in EASYC V2.0 (which we were using to handle the downloads of the new master and default code) but we are not planning to download that code until we can confirm that the default software works.

The issue, at the moment, does not seem to be one of programming the controller as much as one of establishing communication between the controller and the joysticks using VEXNet.

Perhaps I should throw this out as additional question to those who have VEXNet working…

  1. Did you achieve a “solid Green” on the “Robot” LED while tethered?
  2. How long (approximately) did you have to wait for this to occur?

Obviously VEXNet works… IFI is known for releasing solid products and others are clearly having success with it… I’m just trying to figure out what we should try or do differently as we seem to have followed all the recommended steps, as yet to no avail.


As of this morning we have achieved tethered and wireless communication on ONE of our two VEXNet sets… using the same procedures as we described above. Not quite sure what is up with the other set yet…

**When you tether the VEXnet Microcontroller to the VEXnet Transmitter, you should only be worried about the VEXnet LED. The other LEDs will be in varies states depending on how things are connected and battery voltage. Once you have a Solid GREEN VEXnet LED on both the VEXnet Microcontroller and the VEXnet Transmitter, the 2 units are linked together. At this point you can power down, remove the USB A-A Cable, and install your VEXnet Keys. After you connect everything up and turn power ON both units, you should see the VEXnet LED flashing GREEN on both units (takes about 30 secs or less) – you now have successful WiFi Link…… **

Umm… I’m going to fill in some details to the earlier post by Mr. (Jason) Brett.

There’s a robot that can achieve connection and has these lights:

  • Robot Light: Green with one blink
  • VEXnet: Constant blinking Green

Programming is using one of the game templates I think and has Rx 0. However, even though we may be achieving connection nothing is running. No auto, no driver, etc… The code works normally under the old crystal system. What problem might be existing here? =S

  • Allan Kuan

I’m not sue which programming language you are using but for RobotC at least you have to have the VEXnet Competition Switch for anything to run in the competition template.

You could try running codes not in the template to see if they work.

okay. =O

After I posted the earlier message I had literally stumbled upon the VEXnet virtual competition switch in EasyC… but it still didn’t activate the programs inside. =O

I found in another post that there has to be a new template for the program to work… hmm… (thinks of hunting for it later…)