Vexnet syncing error

I am trying to sync my cortex controller and microprocesser and I followed the instructions given to me and it will not sync :confused:. Please help!!! :eek:

Please tell us what each light on both the Cortex Microcontroller and VEXnet Joystick are showing, and also tell us exactly what you did. Both of these will help greatly for the people in turn trying to help you. :slight_smile:

I know you said you followed the instructions, but let me ask a few questions:
You definitely have charged batteries in both the VEXnet Joystick and Cortex Microcontroller?
You turned them both on, and connected them via a USB A-A cable?
You waited until they were connected? (Did they connect? Or is this where you are having the problem?)
Then you turned off both units, unplugged the USB A-A cable from both, connected the Wi-Fi “Dongles” to both units, and turned both units back on?

~Jordan

We have downloaded the firmware to the cortex. We tethered the joystick to the cortex. The Vexnet light was green on both. We add the Vexnet Keys to both. The Vexnet light blinks yellowish Green… fast like it’s connecting. The Robot battery light turn on green. Then the vexnet light goes into a slow green/red blink. then the robot battery light goes off on the joystick and the Vexnet light on the joystick blinks slow red.:slight_smile:

by the way, we are from the same team as poisonjam

As it seems to connect fine when tethered, I’m going to assume that there’s something wrong with one or both of your VEXnet keys. Do you happen to have any extras? Have you tried swapping one or both of them out?

~Jordan

Its not the keys, we switched out two brand new ones and we still got the same results.

Do you have the latest version of EasyC V4? We had trouble syncing, but discovered that our version (CD arrived less than 24 hours before, together with our Vexnet hardware) was already outdated. We upgraded to the latest version (free with a license) at this link and everything worked according to the instructions.

This is very common in the software world (as anyone who has installed Windows can attest). It’s always good practice when installing new software to use whatever utility is provided to make sure your version is up to date.

One thing that would have been wise for Intelitek/the distributors of the CD to do: to place a handout attached to the EasyC V4 CD stating: “Please visit this address for the most updated version of EasyC V4 and follow the instructions below.” For those purchasing the software via automatic download, outdated software is less of an issue.

The only reason why I knew to go to the website was that I vaguely remembered reading about someone having a similar trouble on the forum a couple months before. Sure enough, a bit of searching turned up this thread:
https://vexforum.com/t/answered-tethering-issues/17877/1

For someone making a new purchase who is NOT a forum user, this could have been a nightmare. We unpacked the box with a team of eager members at my home, so we had our forum solution in under 1/2 hour – at school where the forum is blocked, it would have been a wasted meeting. On the other hand, Vex/IFI tech support is top notch, so I imagine that a panicked phone call would have yielded a solution, if we could have caught them during business hours (after school PST is after hours EST or CST, so we get crunched there, too).

While upgrades are good, it’s also a good practice to have products that are fully functional when they arrive new, out of the box.

It’s not the software, we had the latest program updated just before we did this.