VexOS update bricks VexIQ brain

My elementary kids were gifted a couple of brains from a more established program

Info from the bottom of the brains:

228-2540 Logic PCB Rev# 2

Vex Bootloader Ver 1

They were working fine and updated last spring.

I downloaded the new programing environments for this year and it said “Update required”, so I downloaded the VexOS utility. It properly identified the connected brain and all of the connected peripherals.

So I clicked update…

And it bricked the brain. It says VEX Robotics Inc. DFU. Connect to PC for Program Update V1.01 It happened very quickly… the software said it was updating the brain, but the brain instantly went to the “connect to pc for update” screen instead of showing the progress bar.

I tried restarting the robot. And the OS utility. And reinstalling the OS utility.

I tried pressing up/down and then check at the same time to start the brain.

The PC USB recognizes that something connects to the USB port, but the OS utility says Connect a powered on Vex product via USB.

So, the latest update bricked both robots.


Vex tech support was really nice… suggested pressing up/down and starting, reinstalling, waiting and restarting…

No joy.

Vex tech support says if that doesn’t work they’ll happily try to fix them for $50 each. Of course I’d rather not hand over $100 for damage caused by a software update that bricked our robots.

So, where to next?

Pay for the support through the proper channel or buy new VEX IQ Brains. Could take the gamble and buy used from a third party, but you will not have a warranty if something like this happens again.

I mean it could not be a software issue and a bad USB cable the battery was low powered when you tried to do this, PC had a USB port fault out, software is not the only factor here.

And last point is does the brain still turn on and have controls to go through the menu or is it completely non-responsive?


What operating system are you using? Are their any other USB peripherals connected to the computer?
If Windows, what is Device manager showing the Brain as when you connect it?

Do you have anything other than the firmware updater open? I just thought of this one.

Seems odd that a Firmware Update would “Brick” the brain… I’d try a few things if possible…

  • Different USB Cable
  • Different Computer
  • Ensure VEX IQ Drivers are installed (for Windows)… the VEX IQ reports as a different device to the computer in “firmware update mode” than it does in normal working mode. macOS doesn’t require drivers, so you may have more luck there.
  • Ensure that no other software packages are open that would talk to a VEX IQ Brain (i.e. VEXcode, Modkit, ROBOTC, etc.) as this will prevent the VEXos Utility from seeing the VEX IQ Brain.

@pompanoJ - Did you have any luck with getting the brains to respond? I’m having an issue with a possible bricked brain and am looking for solutions. :frowning:

Sorry to revive an old thread, but I noticed that there hasn’t been a reply to this from the OP to what @tfriez suggested.

Just last night I had a similar issue to 2 Vex IQ brains. What started it was similar where the brain indicated some motors needed updating… plugged those in and connected the brain to the computer and ran the vexos util… middle of the process the brain reboots and gives the “VEX Robotics Inc. DFU. Connect to PC for Program Update V1.01”…no amount of re-install attempts would work…

I tried plugging in all the motors to another working brain, and when I turned that brain on, I got the same message. 2 brains bricked. Wondered if there is some issue with one of the motors. VexOS util couldn’t fix this (the install/update would just sit there at like 90% and never complete. I never got the reboot on the brain, and I had to give up multiple times after 30 minutes have gone by).

Anyway, I saw this thread and tried the suggestion given by @tfriez of using a different computer… and that solved it. The brain was in recovery mode… And when the reinstall works, it shuts off the brain and prompts a message on the computer that the brain needs to be turned back on. After that, the OS updates on the brain.

Don’t know what happened, but may need to reinstall VexOS until on my other computer.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.