VEXos Utility 2.0.2 hanging

I had no problem with the version before this summer; I really, really liked it and it was great to be a able to do everything on a Mac since my students all use Macs. But ever since I updated to 2.0.2, it’s been highly problematic. I’m working in Mac OS X 10.11.6. I spend more time with the spinning beachball in VEXos Utility 2.0.2 than doing anything with it. Eventually it recognizes things and seems to work. (But even some of the at working has been questionable.) My biggest headache at the moment is just that it takes several minutes just to get to the point where it starts seeing an attached brain. And I don’t really appreciate having to force-quit VEXos Utility 2.0.2 to exit it, but since I only get the spinning beachball except for short bits of time with a brain attached, that’s the only way to quit the program. I’ve tried downloading VEXos Utility 2.0.2 several times; I’ve tried restarting the computer; I’ve tried closing down other things to isolate VEXos Utility 2.0.2. Nothing seems to work. I can’t be the only one experiencing this.


I’ve moved this thread to an open channel, so that others can reply.

Hey Callen,

Sorry about this issues. What version of the VEXos utility are you using? The there is a date stamp in the lower right portion of the UI window. Are you connected to the internet when you launch the application? Our engineering team is trying to reproduce your issue. We will update with what we find.


The date says 2017/6/15. It’s nice I can see that while the beachball is spinning. :slight_smile: Yes, I’m almost always connected to the internet when I open it.

If I open it up without an internet connection, it doesn’t start out hanging. It gives me that note about being connected to the internet along with a “connect” button. Once I hit the connect button, I’m back to where I was with internet on: same screen and hanging.

More technical data:
MacBook Air
Mac OS X version 10.11.6
1.7 GHz Intel Core i7


Thanks for the info. We are still looking into it. We will let you know.

we had similar issue. the app would simply hang when trying to connect. been using Windows PC desktop ever since and been flawless.

Nice to hear it’s not just me.

I’ve been having the same issue and I need to update around 35 brains in my classroom. Running the latest version of Mac OS and the VEXOS Utility.