Vision sensor "disconnected"

(This may be similar to the “Vision sensor not working” thread, but that’s pretty old so I’m starting a new one.)

My team started setting up a vision sensor, but didn’t get far. The dashboard on the brain does display “objects”, and the sensor top light blinks once when turned on. However, when trying to configure the sensor in VEXcode, the screen just says the sensor is disconnected; there’s no video image. Oddly, the Configure screen says version 0.0.0.

We used this same vision sensor successfully last year. We also tried a second vision sensor, new out of the box, with the same results.

Scratching my head for where to look. Thanks for any ideas.

Try changing the computer or cable used. Alternatively, try just unplugging and replugging it back in.

Already tried unplugging and replugging (both cables), and different brain ports. Will try a different computer (and cables, because why not) at next opportunity, but we tentatively ruled the computer out as a cause because:

  • VEXcode recognized the brain, and the brain recognized the vision sensor; and
  • [I believe, will confirm] we were using the online VEXcode (codev5.vex.com), so unlikely to be a version compatibility issue. I think.

Thanks!

Try installing VEX code on windows. That may work.

Will try, using a personal laptop. (The school laptops are all locked down, we can’t install anything without much paperwork and delay.)

Thanks!

1 Like

You could try to change the wire.

1 Like

Where are you plugging in the computer? Are you connecting the computer to the brain or the vision sensor? Because to configure the sensor you need to connect the computer directly to the sensor.

D’oh! I’m sure that’s it; I recall doing that last year, but I didn’t think to look critically at how the programmer had things connected this time. My bad :frowning:

Thank you, and to everyone who offered ideas.