Vision Utility Trouble

I cant seem to get my vision sensor to properly work with the vision utility. When I plug in I get an image but the utility often freezes and becomes unresponsive. This usually requires closing the utility relaunching and replugging in the vision sensor to fix. In the utility it wont let me set color signatures, the set buttons do nothing. At one point I was able to get one signature set somehow but I could not add another one. When I first got the sensor out I was getting a message saying the camera detected must be unlocked but I haven’t seen it in awhile. I’m running the latest 1.0.9 version but the sensor itself hasn’t tried to update. Here’s a screen cap of what’s happening Vision Utility 0.3.0 Capture.zip (3.9 MB)

That was bug in 1.0.8 that was fixed in 1.0.9

try using clear all and then see if you can set a signature. Which version of OS X are you using ?

6 Likes

@jpearman gives the most common solution, but it may be an issue with your drivers.
If his solution doesn’t work for you, look into system information (On your mac) and attempt to look for serial USB ports in order to find the vision sensor. If its drivers are not correctly installed, its possible that you haven’t installed it correctly. Reinstall vexCode.
Looking at your video, it could also be a corrupted driver, so looking into it may help find solutions.
edit : bad wording

3 Likes

Im on windows 10 and tried clear all a couple times with no effect. I have it working but it seems to be a weird bug, if I select over the the freeze button first then I can select a signature. However it seems it still requires a repug everytime I launch the vision utility to detect. Again here us a screencap of what’s happening. Vision Utility 0.3.0 Capture 2.zip (5.0 MB) Also unrelated but i assume there is no way to rotate the camera`s view? Edit: Just thought i’d add that clicking freeze does not make signatures selectable it requires dragging over it.

My students found that the black USB cords that come with the brain are not very good with the vision sensor. We went to dollar tree and got these:

And they work great.

1 Like

Full Disclosure: I am a total novice at VEX projects!

I am finding the Vision detector to be particularly troublesome. Initially I had the same issue as Zack, in that the camera seems to be very sensitive to the cable used to connect to the computer. Out of 4 cables I had on hand (from different devices) 2 worked 2 didn’t. By “worked” I mean 2 cables connected to the Windows (10) PC could ‘see’ the device as the VEX Vision Sensor and 2 would not (although the LED did light).

Once connected a good cable the performance is still very variable, sometimes the “Vision Utility” connects just fine, other times it gets ‘stuck’ saying “connecting” on the screen. After exiting the Vex Blocks program and sometimes “rebooting” the computer it will work again and connect almost instantly. 2 minutes later I come back to the Vision Utility and once again it gets “stuck” connecting.

Any ideas?

Thanks
Nick

1 Like

I have not had issues with any particular cable, I do find that I need to unplug the cable (on the PC side) if I have just used the vision sensor with the V5,
I .e.
if I

  1. configure
  2. test that configuration with code on the V5
  3. Try to configure (Connect) again, - At this point I need to unplug the cable between the PC and the Vision sensor, ten the config utility connects right up (for me)

Other than that I have had no real issues.

Hope this helps.

Thanks.

After reading your reply and doing a little “Googling” it turns out there are USB cables that are “Power Only”, the data pins are not connected! Some cables actually have this printed on them (see https://electronics.stackexchange.com/questions/140225/how-can-i-tell-charge-only-usb-cables-from-usb-data-cables) however most don’t. So “Buyer Beware!”

nick