VRC Error Problem: fatal error: 'sys/config.h' file not found


#1

I realize that this has been posted before here.

The answer said this.

I got this error:

13:42:30 -- error -- In file included from ../vexv5/gcc/include\stdlib.h:11: 
../vexv5/gcc/include/_ansi.h:16:10: fatal error: 'sys/config.h' file not found 
#include  

I went into my school computer and attempted to change my current directory to C:/AppData. And there is only one folder: roaming. After changing directory all the way through I get to:
/c/appdata/roaming/vigyanlabs/IPMPLUS 1.8.41.0/install

That’s clearly not right.

I then tried to change my current directory to C:/ProgramData I get:
asdf

Does anyone have any ideas? Thanks for the comments :smile: .


#2

Go to %LOCALAPPDATA%\VEX Coding Studio in Windows Explorer (instead of %userprofile%/AppData/... as the other answer suggested).


#3

We have had issues like this on our school computers as well, although it wasn’t the specific file “config.h” that was missing, it was a different header file that I don’t remember the name of.

As a precaution, I would recommend backing up any programs before doing this(IE to a flash drive or online just to be safe).

The way we fixed it (although if anyone had a better way of fixing it, I would recommend that over this) was by first closing VCS, then going to C:\Users\%username%\AppData\Local\VEX Coding Studio ( change %username% to your current username) or %LOCALAPPDATA%\VEX Coding Studio (as edjubuh mentioned before, and deleting the Vex Coding Studio folder.

The next time you start up VCS, this folder will be recreated, and shouldn’t have any files missing.

Hope this helps!


#4

I had this problem, and went the complicated route to fix it, but you just should delete the VCS folder as everyone else recommended.

I ran a file comparison script between one of our computers and the one with this issue, identified the missing files and copied those missing files over, it now works fine.


#5

@Nerdom Can you save me from doing the same thing… What/where were the file that needed to be copied over?


#6

We had the problem on 2 computers that had completely different files missing. If you’ve got an installation that is working, I’d recommend uploading the folder to GD or something and just replace the folder (aka paste it’s contents and just mark it to skip all duplicates)