weird problem with motors

Hey guys,
Worlds is just around the corner, and one of the robot has a weird problem. About 30seconds to 2minutes into continuous driving, one of the motors (4 motor drive) starts to lose power horribly for some reason. This makes the robot unable to drive forward or backwards straight because one side is dragging.
I know for a fact its not a programming problem, it may be a building problem/faulty motor, however this doesn’t explain why it is fine when it is first driven, and dies out afterwards. The motor does continue to stay dead even if it is turned off and on.

I was thinking perhaps it may be over heating; however, we have felt it, and it is barely warm. Any thoughts, or have any one ran into a similar problem? Thanks,

We actually have a very similar problem to you and we solved it by removing a lot of the friction on the axle. Erm, I actually dont like the way I said that… umm, we added spacers and realigned everything so that the only strain on the motor comes from moving the bot. I’m sorry I cant give you a more technical answer, but by lowering the load on the motor the problem was solved…

Both overheating and overloading can stop the motor, and those two causes are *not *independent.

When the motor stops, is it the motor or the controller doing the stopping? That is, if you swap connectors, will that motor run if driven from another port? Contrarily, will a different motor run if driven from the port to which the stopped motor was connected?

Similarly, is the problem the motor or what it’s driving. If you decouple the motor from its load, does the problem occur? If so, does the effort to spin the connected mechanical load by hand feel similar to the loads on other motors? (This may be very difficult to check, as whether the robot is sitting on its wheels can make a critical difference in how much drag there is on a drive train.)

If it is the motor, it’s possible that the thermal sensor in that particular motor module is more sensitive than most, so your best bet is to swap motor modules.

If the problem is the controller port, try swapping those.

Happy Hunting,