Weird symbol on v5 controller

image

There is a weird symbol on my V5 joystick controller. What does this mean??

2 Likes

I’m a member of @TheWeirdoRobot’s team. We recently updated our controller and that’s when the icon appeared. We’ve been trying to test our auton for the past 30 minutes and when we go into Programs>(Our Code)>Timed Run and press A, nothing happens. This has never happened before. We have three versions of code on our robot (for red, blue, neutral) and we’ve tried using the Timed Run on all of them-- no luck. Does this icon have anything to do with our Timed Run malfunction?

edit: Also, we’ve tried resetting our controller multiple times. Icon does not go away.

1 Like

I believe that symbol is displayed on the controller when the controller connected to a competition switch and the switch has the driver control enabled. Is your controller connected to a competition switch? If you turn the controller on and off, does the icon come back? If driver control is enabled on a competition switch connected to the controller, I imagine that the auton would not run if you did a Timed Run.

4 Likes

That must be our issue. Last Friday when one of our team members was trying to update our controller they plugged the brain into the controller using a smart cable but accidentally plugged the cable into the port on the controller meant for the competition switch. Our controller started smoking, which @TheWeirdoRobot posted about earlier… we must have short-circuited our controller and now it thinks it’s constantly plugged into a competition switch. We’ve tried resetting the controller, turning it on and off, and the icon never goes away. I think we’ve damaged it internally. Time for a new controller, probably!

Yeah. The controller is probably fried, just not enough to die completely. Definitely get a new controller. Good luck with that!!!

1 Like

yes, you have fried the ESD protection circuit and shorted some of the competition input pins, I actually managed to do this on one of my development systems.

6 Likes