When I am using the two motor drivetrain without a gyro, the set track width parameter has no effect on a turn

I am using the two motor drivetrain. I have configured the drivetrain without a gyro. When I use the Turn Right for 90 degrees block, the bot turns, but the turn is much greater than 90 degrees. I have tried changing the set track width parameter, but it does not seem to have any effect.

A screen grab of the program and configuring the drivetrain is attached.

I am using Vex IQ Blocks version 1.0.7-197.

bmp

My students had this same problem in vexcode text this year, here are some of the top things to try:

  1. triple check the units on your track width.
  2. when you change the units on your track width it converts the previous number, so you might have to change it back.
    3)Make sure stopping mode is set to brake
    4)Make sure 2 of the 4 wheels are omni
  3. Make sure there is no extra friction on the drivetrain from being misaligned or bent shaft ect.
  4. Try playing with the track width in ridiculous increments. For some reason some of my kids had a 10in wheel base, but they had to run it with a 3in wheel base to get it to turn properly. I don’t know why.
  5. Finally if all this doesn’t work just “hack” the system by adjusting how many degrees you want it to turn. For example if it turns 110 when you put in 90, then put in 70 and it will overturn to 90.
1 Like

Just for fun, I coded up 90 degree left and right turns, doing all the calculations myself. A screen grab of the Vex IQ Blocks version is attached. The turns are very accurate.
bmp

1 Like

Looks great. Now you can make a MyBlock out of it!

1 Like

We’ve added the “wheelbase” parameter to IQ Drivetrain devices in 1.0.8 to account for custom robots that may varying distances between front/back wheels.

1 Like