Why does V5 cable work for Antenna but not for Motors?

One issue I am having is wires that work for my antenna and tethering my controls together or to the brain, but when I use the same cable to connect to the brain it does not work.

So are other users having the same issue? If so, does anyone know how to fix that?

Thanks

Are you sure the motor works? The motor pins may be broken

Yes I am sure, I would plug each wire from my control to brain to see if it links, so I test every port. Once I know the cable links, I would use those cables on the motors. Once I have a cable that links to the motor, I test each motor. Once I know each motor works, I then go to the port that the motor is programmed for. I test all ports for the drive and everything is properly programmed.

So now I know everything works, all motors work, the program works, all the wires work. But something weird happens when I plugged in wires I already checked. Some work and some don’t work when I plug it into the motors. I checked these wires with the Antenna, it works, but I plug the same wire into a motor but it doesn’t work.

So not sure what is going on, I even made new cables. I cut off the ends and re-crimpted new ends. And the same thing happened, some cables worked for motors and some did not. Even though all of them worked for the controller link and antenna link.

1 Like

Sounds like it could be a bad wire. Motors get power through two of the wires. Since the antenna is not powered, I am guessing one of the two wires hat carry could be disconnected. So you wouldn’t see a problem for the antenna but you would for a motor. This is all a guess on my part, though.

1 Like

Everything using a smart cable needs power*. I would assume “antenna” is really the VEXnet radio, it needs power.

*except perhaps the controller, although it can also use power from the brain when tethered.

3 Likes

I thought of that when I wrote my post (because the antenna has a light) but assumed the small amount of voltage to light it up came from the control wire not the power wire. But, like I said, I could be completely wrong!

1 Like

Have you checked to see if each end pin has continuity with the opposing pin end using a multi-meter

1 Like

Few months ago we bought 3rd party 4P4C connectors. We crimped several custom cables and tested them with RJ11/RJ45 tester - everything checked out fine.

However, when using those between V5 brain and motors - the motors would blink red and not run. Radio worked fine with those cables. Also, if we insert/remove those connectors from the motors and brain ~ 40-50 times, they would start to work but sometimes drop connection later.

We got connectors sold by VEX, recrimped the wires, and didn’t experience problems after that.

This leads me to believe that there are small variations in the in the thickness of the contact pads that prevent it from making proper electrical connection and support full load. Connectors sold by VEX must be on the same side of the tolerance range as V5 components allowing more reliable connection.

4 Likes

Everything I bought are VEX, so unless the connectors and cables are defective it still doesn’t explain why it works for one thing and not another.