Windows 7

I’m thinking about moving from Windows Vista to Windows 7 and I wanted to know if it would affect EasyC, RobotC, or Mplab in any way.

No… Not a Problem… BTW, Windows 7 Professional reports Version 6.1

EasyC–> EasyC 2.0 and Windows 7

RobotC–> Re: Vexnet with robotc

MPLAB–> (Vista Support is a given, no mention of Windows 7)


MPLAB Update–> I installed MPLAB 7.50 and MCC18 on my Installation of Windows 7 Professional.

I have Windows 7 Professional installed, and I cannot install the easyC Pro software at all. I get the “Starting Error” every time, just at the end of the installation. I looked for updates and found them on the VEX site, but the result was the same. I tried to install the USB driver first (which installed without issue) and then the easyC Pro install off the VEX site, but that didn’t work. This is a brand new computer (2 weeks old) with Norton installed from the beginning. I have tried setting the installation to compatibility mode (Vista as well as XP), then setting the installed program the same way.

You see, the files are installed, but the installation never completely finishes, so the easyC.exe app complains we you run it that the installation never finished (Error #0001). Suggestions?

Try running the EasyC App as an Administer, not the Current User the first time, to finish the Initialization and to Register it.

Thanks for the suggestion. I deleted the files and tried to reinstall, setting the compatibility mode to “Run as administrator”. Same error. Any more ideas?

On my system I have set it up so that it auto elevates all programs that I run to administrator so I don’t have to click run as administrator every time.

Also check to see if you are running a 64bit windows 7 system because if you are trying to install 32bit software there is a chance it might give an error. I have 64 bit win 7 and I have only had an error a few times with some large software packages that were 32bit but most of the time the small 32bit programs I installed worked without a hitch.

Just a thought…

When I installed on Windows Vista Home Premum, I had to select with the Right Click Menu, “Run as Administrator” for the Install Program. Then, after it was installed, using the Windows Explorer, I had to Right Click on the EasyC Program itself, and Select the “Run as Administrator” option as well for the First Run. After that point, I could just Double Click the Shortcut to start EasyC.

easyC is tested and works with Windows 7 32bit/64bit. If you are getting a starting error it is usually a problem with your installation of Windows 7. Please give customer support a call and they will take a look.

I have been running RobotC with Windows 7 for about a year (Beta + RC) and it works fine. The “Unable to create empty document” error was fixed, there was a problem with the installer. On my computer RobotC runs fine, but sometimes the debugger crashes the program so you might want to save often. It would be good if you asked a professional from CMU b/c I really have no idea much more than that.

I just recently bought a new Notebook that came with Vista, but through the promotion, I have a Windows 7 upgrade coming in the mail. The hard drive came partitioned into 2 drives, a 149 GB and a 137 GB partition. My issue is that I’m concerned that some of my software won’t work with 7 as it would with Vista, so my plan is to copy over my C drive in place of my D drive, keep Vista on that one, and upgrade my C drive with the Windows 7. Space isn’t an issue since the drives internally are bare, I work out of a 500 GB external hard drive, makes gaming easier between my Notebook and my Desktop back home.

I’m not sure how or if I can copy over drives like that. My goal is to be able to boot out of either drive, so my question is is there to accomplish this easily and without having to spend a bunch on a partition copier?