Wireless debugging in PROS

Today I was trying to debug my code using the serial programming kit (the old one with the serial connector). Although the robot code ran fine, none of my printf statements showed in PROS IDE’s terminal window. Instead, I got something along the lines of “NO SUCH PORT COM3”.

I followed the exact instructions listed in the PROS documentation, including setting the baud rate to 115200. The drivers on my computer are also up to date. I’m on Windows 10 and PROS version 2b09.

Honestly, I would much rather use the orange USB A-to-A cable, but that would make it impossible to debug with a joystick as the cable would occupy the Cortex’s USB port. I need the joystick because I’m trying to tune a PID loop in my code.

Here is a picture of the programming kit I was talking about. Hopefully this clears things up a little.http://www.robotmarketplace.com/images/store_vex_program_lg.jpg

Hey fiang

My first question is that are you running the latest version of PROS? Judging by your link to our old documentation I suspect this may be an issue. The current version of the IDE is 1.6 and can be found here. I apologize on the confusion with sourceforge as we are in the process of taking that project down.

If you are running the lastest version please message me or post here your workspace log file which is located within your workspace at


So I tried the same debugging procedure on the most recent version of PROS. Unfortunately I’m having the same problem. I’m also unable to send code using the serial programming kit, which is currently hooked up to the PROGRAM port on the joystick. Strangely enough, the serial programming kit is recognized in the Device Manager, but when I try to send code PROS complains about it being missing.

Here is the workspace log file. I had to add the file extension so it would upload properly.
log.doc (472 KB)

Hi fijiang,

After inspecting your log, it’s likely that TM terminal isn’t properly configured right now as you expected (see explanation on p167150). Here’s the simplest thing to to do right now:

Will you open Command Prompt and/or Run the following command:

C:\Program Files\PROS\pros.exe --clean


I ran the command in your post. Unfortunately, nothing has changed as the programming kit still isn’t being recognized by PROS. However, I can send code and debug using the normal USB A-to-A cable.

I’d like to verify that it is indeed the PROS IDE that’s having issues. Can you open Device Manager? You should see a device under the COM Ports section. If you do have a port listed, I just realized you said you had opened Device Manager. Go ahead and: download PuTTY and open it. Configure it like this, changing the COM3 to whatever COM port was listed in Device Manager. You should start getting debug data from the Cortex. If this is not the case, or you do not have the device listed under COM Ports in Device Manager, ensure you have the latest drivers from VEX. A typical installation will include most drivers, but there are a few legacy drivers that we don’t install.