Wireless programming

As the new firmware 4.2 was released alongside huge updates to easyc and robotc, has anyone tried to use the wireless programming feature with vexnet 2.0? We have had no success in doing so

Wireless programming works very well, I have had no problems with ROBOTC, EasyC or my own open source tools. Wireless debugging in ROBOTC still needs some refinement.

Does one need the newer orange serial cable to do wireless programming? I tried downloading the drivers for the old serial cable. It pairs but code doesn’t download.

NOTE: I am using VEXnet 1.0

Both new and old programming cables can be used with both VEXnet 1.0 and 2.0. There have been issues with the old cables in the past, prolific (who makes the USB/serial chip) have had problems with counterfeit parts and try to detect these in their drivers. The VEX wiki has links to drivers that work with various versions of windows.

I am using the old wireless programming cable and I cannot get it to work. When trying to download the program, it says failed to get vex system info! Updated the firmware of both the joystick and the cortex, still no success

Go to the windows device manager and see if the prolific driver is loaded correctly, click on ports and see if there is a yellow warning triangle.

i have the old programming hardware kit and works fine on robotc with vexnet 1 & vexnet 2 …

i am using vexnet 2, works fine … haven’t spotted anything major yet

Pkanhe1, are you running windows 8?

Nope, windows 7! Still doesnt work wirelessly with 2.0… I guess the programming cable is bad