Won't Save


#1

I keep getting a “failed to save” message when I try to save a program created on Modkit Desktop version. Since it is on the desktop, I am saving to the computer itself and not online since this is a downloaded desktop version of modkit. It was working fine until today. Please advise. I have tried rebooting the machine.


#2

I am still unable to save our programs. ???


#3

Try changing the default directory. When you browse to open a program there is a Change button that allows you to select a different directory. Is it possible something is wrong with the current directory, like it is a network share that is not available, or the permissions have changed, or it has no space left?


#4

Thanks! I tried saving to another directory and it now saves.


#5

That’s good news.

Another way that the default directory can inadvertently change is if you open a program by double clicking on it from the Windows File Explorer or Mac Finder. The directory that the program you double clicked on is now the default directory. So let’s say that someone gave you a program on a flash drive, and you double clicked on it which opened it in Modkit. The flash drive is now your default directory, and if you remove it from your computer you won’t be able to save anything until you change the default directory.


#6

Sorry for reopening an old thread, but I am currently experiencing the same problem with the “failed to save” error on the Modkit offline (desktop…well, laptop in this case) version. I tried the suggestion above, created a new folder and changed the default directory for saving/loading the programs to/from this folder. Unfortunately, in my case this solution did NOT work. It also makes no difference whether I’m trying to save a previously created program (with or without any changes) or a newly created program. ALL of them suddenly bring up the “failed to save” error. I’ve ruled out any virus, malware and spyware infections on my system (3 days of thorough scanning), there is plenty of storage space left (200+GB) and a reinstall of the Modkit program didn’t help either. I’m at a complete loss as to what could suddenly be causing this problem or how to fix it. Any help or advice would be greatly appreciated.


#7

What happens if you right-click on Modkit snd choose Run as Administrator when you load Modkit?

Also, if you put a USB memory stick in can you save to that?


#8

Thanks for the suggestion, calvc01.
I haven’t tried that, but will keep it in mind if the problem returns (hopefully not).

At the moment it’s working again after I created another folder directly on the desktop
(outside of any other directory), copied all of our previous projects into this new folder and
changed each project’s name. This new folder is now the default directory for loading/saving
projects and so far it allowed me to save edited and also newly created projects.
Not sure why it works like that, I’m just glad it does! :slight_smile: