Yet another disconnection thread

Hello all,
So I apoligize in advance for adding yet another disconnection thread to the forums. However, our issues are a bit different and I’m beginning to stress out a little bit. I’ve tried every single thing I can to fix our issues and at our last competition, it didn’t work.

So for a little background, we have been having disconnect issues all year. However, after the last post I made about disconnecting, it seemed to be fixed. We took the advice of those who posted and changed keys, taped and rubber banded both keys, taped battery connections, and tried anything else we could think of and it seemed to fix it. However, at our last tournament, disconnects absolutely killed us. I ran a ton of tests the night before and was working on our autonomous so I was plugging and unplugging my cortex key a lot. However, I drove it for a considerable time after with no issues.

The morning of during inspection, our firmware was out of date so the inspectors updated to 4.1 as is required. However, upon going back to the pits, our controls were a little messed up. The joysticks would be half our lift and half our drive and the buttons for our intakes did our pneumatics. Everything seemed to be switched. It did the same thing to all five of our teams.

I re downloaded the old firmware to my CPU and controller but had serious issues with it. The computer wouldn’t recognize the CPU being connected for a while then when it finally did, it wouldn’t let me download my old program on. I tried a ton of different things and finally just rebooted the computer. It worked and all our controls worked well again. However, we started to have disconnect issues right after.

We would have a green light on the controller to start the match for all but the robot light which was red. We would start the match and in two matches, our autonomous would go forward and knock the big ball off but on the return trip to our starting tile, it would stop working. It would sit until the end of autonomous. I would turn my controller on and off and regain the green on my controller. Then we would start the match and within five seconds, we would lose connection again. However, this type of disconnect is different than any other one we’ve encountered before.

With our old disconnects, we could turn our controller off and on and simply cycle it to regain control. However, with this one, the actual VEXNet light on the cortex would be a slow red flash. No other lights would be on. From experience, we know there isn’t anything we can do with that. We just had to sit for a whole match and watch as a robot knocked a big ball off the rail to win the match. All the other robots were just sitting. Team 21 ended up showing that the tower we had been connected to for that match was faulty and messed with a lot of people who were connected to it. However, they could pull the cable out of their controller and continue driving once that happened. With ours, our cortex was just shut off. It wouldn’t matter if we pulled out our cable.

For even more information, we use EasyC V4, we have no IMEs, and just two potentiometers to tell which programs we will run. We don’t use an LCD screen, have a power splitter, and are driving with four omni wheel drive that has all motors internally geared for speed and have a 1:1 external ratio.

At is point, I’m a bit at a loss. I don’t know how to fix our issues anymore so any help would be greatly appreciated.

first. when you update firmware you need to recalibrate the joysticks.
instructions on how to do that:

Second, EasyC hasn’t released anything since the new firmware was announced so it doesn’t recognize it. to solve this you need stop it from verifying the master code. as can be seen in this thread:
there was also a nice picture about it but I found this first.

as to the vex-net disconnection, could it be the battery connection?

Do you have much metal 2" within the tip of your Vexnet key? When we had lots of metal around our Vexnet we would disconnect sometimes. The slow blinking red just means it is disconnected. Try turning the remote off, unplugging the remote, re-plugging it back in, and turning it on. This will sometimes help it reconnect. If you unplug it, it will help the reconnecting process, I have found.

I have still to make a post about the ridiculous situation of updating firmware at this competition, I was not happy with inspection to say the least.

Do you know any more details about what was claimed to be faulty? I heard rumors of things like “the field controller erased our autonomous”. As you know, I was at this competition, teams are always quick to blame the field control system, most of these claims are usually proven to be false. All field control can do is select driver or autonomous and then enable and disable the robot, nothing more. Correct operation of field control is easily detected by using the diagnostic leds. The more likely problem is that the school does not turn off any of the several WiFi networks that you have. The situation we had Saturday where elimination matches started to be replayed was quite unsatisfactory.

Second, EasyC hasn’t released anything since the new firmware was announced so it doesn’t recognize it. to solve this you need stop it from verifying the master code. as can be seen in this thread:…light=firmware
there was also a nice picture about it but I found this first.

Ok thanks for that. I will start working on that stuff.

We used various batteries and had certain ones taped and certain ones not. It didn’t seem to make a difference unfortunately.

Hm interesting. We have one c-channel a few inches from the key so maybe that could be doing it. And ok I will try that next time.

Hello Mr. Pearman. It’s nice to be able to put a face to a username now. Regarding the faulty field argument, I’m not entirely sure what they claimed. I know the head referee ran light checks and such on the towers and it seemed to all check out. The next test they ran was a driving test. I saw two 21 teams drive for a while then 21D stopped working in the last few seconds. They unplugged their controller and immediately regained control. I don’t know much else though. I wasn’t paying a whole lot of attention because I thought we would be going right after.

Thank you for posting this, exact same disconnection problem happened to us at a tournament in February. We worked the first two matches, but not the rest of the day. The judges watched as we would disconnect the minute the timer started, they replaced the cord to the tower. That seemed to work for about 30 seconds. We worked then slowly went from green to yellow to red.

We called VEX, they suggested updating to Robot C 4.0, we did, but now we have the problem that we cannot compile and download. The error message says it is not connected to the robot, even when it is. We are trying uninstalling 4.0 and reinstalling (tried that 2 times so far) still no luck.
Is there a way to test if it is the connectin tips on either the battery or in the cortex.

Other suggestions?

Coach Mom ~

Which led went from green to yellow to red?

Did you update both cortex and joystick to V4? Make sure it’s the latest 4.01. Are you using EasyC? If so then you may need to turn off the “check vex system” (or whatever it’s called) in the options dialog so that EasyC does not check for the cortex version and abort if it’s not exactly what it wants.

Were you ever able to fix this? We fixed the issue by restarting our computer. Then it suddenly started working again. I’m honestly not sure why but at that point, I wasn’t going to question it.

I’m sure there are but I am not aware of any personally.

I don’t have any suggestions really because I have a limited knowledge of what the heck actually happened. Mr. Pearman would probably be better at explaining the intricate programming things because he has experience with that. However, I can tell you what we did to attempt a fix.

During check in, our firmware was updated by the check in crew to 4.0. We have been using 3.# (Not exactly sure the number… think its 6?) so when we got back to the pits, it really screwed up our controls. That happened to all five of our teams actually. Anyways, I ran for our computer and used it to downgrade our firmware back to what we originally had. I did that with both the CPU and the controller. I then tried to compile and download our program back onto our CPU but it wouldn’t recognize the device being connected. We tried plugging the cable in to the different USB ports on our computer, replugged both ends of the cable in multiple times, shut down EasyC and opened it back up, etc. Nothing seemed to work. Finally, I shut down the computer and rebooted it. I reopened EasyC and the program finally downloaded.

I hope you are able to fix the issues. Also, if your disconnect issues are fixed by some magical remedy, please let me know. I think we are still having issues with ours and it has become quite frustrating.

Another culprit can be shorts due to nicked and exposed wires causing short. Check your wires (especially where they turn corners or go by cut squares).

They can be quite deadly to your robot.