Brain Isn't Working

When I turn the robot brain on, the vex logo pops up, and that’s it. After it does this, the robot brain never fully turns on, so I can’t download new firmware. I’ve tried using a different battery, I’ve tried recharging the battery and putting it back in, I’ve tried unplugging everything, but it still doesn’t work. Any suggestions?

Video of it not working properly

2 Likes

Hi UserName,

We’re sorry that you have encountered this issue. To help resolve this issue, first we will force the Robot Brain into firmware update mode, so we can reinstall the current firmware.

Please first remove and then reinsert the Robot Battery, then disconnect all Smart Motors, sensors, and radio from the Robot Brain. Then press and hold both the Up and Down buttons at the same time while pressing the Check button to turn on the Robot Brain. This will force the Robot Brain into Device Firmware Update mode.

If your Robot Brain displays the following text, you can now connect it to your computer and reinstall the current firmware:

VEX Robotics Inc. DFU

Connect to PC for
Program Update

v1.01

If you do not see the above text on your Robot Brain screen, or if you have any additional questions or concerns, please contact VEX Technical Support at support@vex.com or by emailing +1-903-453-0802 so we can provide more detailed help to resolve this issue.

Regards,

  • Art
1 Like

I am having the same issues and we have a competition coming up. 2 Brains in one day this has happened to.

Do you know why this is happening? 2 Brains dead in one day. Very frustrating .

This thread is dead
Start a new one
I summon you @DRow

Not sure why there is a search button if we have to start new threads for relevant topics. oh well.

This topic is 4 years old, there’s no guarantee that the original posters are vex forum members with such an old thread, a lot has changed over the last 4 years.

Have you tried the procedure that Art explained ? Make sure no other programs are open (VEXcode blocks etc.) when trying to do a firmware update using the IQ vexos utility.

4 Likes

true…thanks…yes, I did was able to get it working…just wondering if it was anything on my end.

I would need more details, how/when did the error happen ? Were they brand new brains ? Were you trying to do an update etc.

3 Likes