Cannot download to brain on Windows 11 Home

I cannot download to my brain on the Controller, or Brain. I have tried a factory reset, different cords, different brains, different programs, and re-installing vexcode v5 pro and vexcode v5 blocks multiple times. I can’t seem to fix it. Anyone else have this issue? If so, have you found a fix?

My guess is that Windows 11 is not supported yet on both VEXCode Pro and Blocks. I would use a device with Windows 10 or a macOS for the time being.


For the most part Windows 11 is a re-skinned Windows 10. It should work as if the operating system is Windows 10, so I would assume the issue may lie somewhere else.
@taco did you try reinstalling the drivers for the V5 Brain?

1 Like

Windows 11 should not be the problem, I was able to download to v5 Brain with no issues.

1 Like

i have a couple questions,

is the brain showing up? or is the brain connected just not downloading?

if the brain is connected just not downloading, do you get a download/ build error? if so, what does it say?

if the brain is just not showing up, have you tried with different ports? different computers (ones on windows 10 and 11) ?

Windows 11 still has many issues that need to be ironed out with it because right now it is like a chromebook. There all the same but because of different hardware and the software not being fully universal yet it tends to lead to several different problems.

I haven’t seen many issues with windows because like @Connor said

when looking through the official Microsoft bug reporter, most issues seem to be with windows itself (and for some reason a lot about the keyboard), and not how windows runs apps. i know many people with windows 11 and all of them can download to the brain just fine. it could be a problem with windows, but it is most likely a problem with the v5 hardware or v5 software (or user error), not a problem with the windows 11 operating system.

1 Like

I have tried re-installing the drivers and it just doesn’t seem to work. I could download fine when I was using windows 10, but when I updated to windows 11. I have tried different cords and ports a etc. I just don’t really know what to do at this point. It is rather annoying.

Some USB ports may be prone to dying on computers due to overcurrent and other types of problems. Did you try plugging into a different USB port? Could u try using the controller’s micro-usb port instead to see if there is a link with the computer, alongside trying a different USB port on the computer?

I am having the same problem. Windows 11 connects via USB and Brain shows up green with Brain Name, Brain Generation 1st, and and VexOS 2.2.0 all correct. However, no matter what I try or bounce, the download icon is never enabled.

As a Windows 11 user, I had no trouble downloading code to my robot.

I also have no problems downloading the code. It may be an issue with your application, or something else.