Coding on PROS with M1 Pro MacBook Pro

Hello,

I recently installed the PROS extension on Visual Studio Code. However I am running Monterrey on a M1 Pro MacBook Pro, that is of course ARM and not Intel based. While the extension downloaded and appears fine, when I attempt to install the CLI (command line interface) the installation proceeds as normal but takes a long time and eventually times out. How do I fix this, or does anyone have any tips?

Thanks!

You might want to try to run it under Rosetta so it uses the intel architecture

Ok, I know what Rosetta is, but how do I “manually” do that if VSC is showing as Universal and not Intel based? Is there a manual way to make it kick in?

  1. Click the desired Mac app’s icon in the Finder.
  2. Click the File menu in the Finder and choose the option “Get Info”.
  3. In the Get Info window, tick the checkbox next to “Open using Rosetta”.
  4. Close the Get Info window.

Credit and more info at: https://www.idownloadblog.com/2020/11/23/enforce-rosetta-emulation-tutorial/

1 Like

Follow Linux install instructions on Mac M1 it works fine - also you can use latest AtonIDE build - yes no button integration but everyting else works

1 Like

It does work on an M1, I am using it. However, it was working on my old i9 Mac when I used the migration utility to move everything to the M1. So I didn’t have to install it on the M1.

So you are telling me to install the Linux version, even though it is Mac OS?

Good to know! But quite possibly that might be why it works, due to importing a Intel app?

I appreciate all the suggestions. However I tried installing any combination of VSC in Linux and non-worked. In addition, I tried to install Atom and/or the CLI through other methods on an Intel Mac and that didn’t work.

So essentially I can’t get PROS to work on VSC on a M1 or Intel Mac.

Am I doing something wrong? Any other help is appreciated.

Also I haven’t even gotten to potentially trying PROS on a Windows machine.

Thanks!