Cortex Controller Blown?

Hello, I have just ran into a problem that I have never experienced of heard of. My brain has been working without a problem then I get home and it would not connect (this was a couple hours ago), I did some wiring and now when I put in a battery there are no lights on. The battery is fresh and it turns on the power expander when plugged into it but the brain wont do anything. I tried to pair it to the controller and the controller lights turn on but when I plug it into the brain the controller lights are extremely dim and red. I do not know what to do. I plugged it into my computer with the AA cable and I get an error message that pops up on my main screen and it says there was a popwer surge in my device. Is my brain dead? Is there anyway I can reset it? If anyone has any idea and possible solutions I am open to anything right now.

It sounds like the power is short circuit, ie. the positive and negative power are connected. Is anything connected to the cortex, if so disconnect everything, sensors, motors etc. and try again. If everything is disconnected and you still have the problem check that nothing has fallen into the cortex. Also check the backup battery connector has not been damaged inside the cortex. If you see nothing wrong then call VEX support as repeatedly connecting the battery may cause more damage.

I just unplugged everything and it works fine and connects quickly so I started replugging everything in and it is when I plug in the LCD’s it wont work. Both the uart ports are making it short out.

My guess is that it is the cable connecting the LCD, not the LCD itself. I would check the cable for any signs of damage or better yet borrowing or purchasing another cable.

So one of threes things can be wrong.

  1. cable plugged in incorrectly, I doubt this is the issue but it could be.
  2. damaged cable
  3. damaged LCD

Check the cable, it is keyed so you should not be able to plug it in backwards, however, check that the white wire is closest to the motor ports on the cortex. When looking at the front of the LCD, black is on the left of both rx and tx ports.

plug the cable into the cortex but disconnect both ports of the LCD, if you have a problem now then the cable is perhaps damaged.

look into the ports on the LCD, are any pins bent?

Okay I will look into that. Also when I turn it on, all my lights turn green how they are suppost to but then the robot light tunrs off and it just blinks. The motors do not buzz. I have re-paired them, re-downloaded the code and the master code and still nothing. Any idea what may be my problem?

From what I remember this is a problem with the user processor, the cortex user guide should tell you. Lets get the basics out of the way.

Edit: what color does the robot light blink? I assumed red but is it green?

ROBOTC or EasyC?
which version of the above?
Which master firmware?
What is the hardware rev of the cortex (look on the bottom)?
Are you tethering joystick and cortex with the USB cable or using it via WiFi? If it is WiFi try running tethered joystick to cortex.

was this code working before? can you download something simpler, say just one analog joystick to one motor, does that work.

We are using EasyC V4, version 4.0.4.6. The joysticks mastercode is 3.20 and the Cortex is 3.21. The light would flash red and even when it was tethered straight to the robot it wouldnt work. I just downloaded a simple code and it seems to work just fine. We recently added some pneumatics and a 2nd LCD screen but that is the only thing that has changed.

Ah, the plot thickens. So you have two LCDs ? Does connecting one or both short the power out? (that’s a different issue but was your original problem).

Do you have the previous version of code that did not have a second LCD? can you try that? can you disable the code communicating with the (now disconnected ??) second LCD.

Was the code with two LCDs working before yesterdays problems?

As you know from your team mates post a couple of weeks ago, EasyC has a “feature” where using any LCD to much can crash the code, I have no idea what may happen with a second one connected.

The only problem we has yesterday was that the 2nd LCD wouldnt display our backup batteries voltage but other than that it worked and last night I wired everything and it doesnt work. We took out all the unnecessary LCD text and it worked better. I can try taking out the 2nd LCD out of the code and see if it works then.

Yes, comment out all calls for the second LCD.

btw, are you using the “patch” I posted here for dpbailey? If so, this was not intended to be used with two LCD displays, it only stores the text for one. You are the first team I have ever encountered trying to use two. It could certainly be modified quite easily, let me know.

I believe that we are not using that. I am not 100% sure of it though. Are you and your teams going to be at worlds?

The three 8888 teams did not qualify for worlds, we came very close several times but just could not quite make it. I’m sure some of the students will be there cheering for the local teams including yours.

I am volunteering and will be helping the organizers, I’m looking forward to it.

I had a interesting and somewhat alarming incident a while back when using home made LEDs to give feedback of what mode the robot was operating in (manual, line follower gyro tracking etc.) I must have had a short somewhere in the LED extension cable. The first observable I had that something was wrong was related to my Optical Quad encoders, they stopped reading change. As I started to troubleshoot I also began pulling sensor cables out. it was then I noticed the Cortex was really hot. so I disconnected every thing. let it cool down for a while I still had no luck when I added the OSE sensors (still showed no reading) I left the robot for over an hour, after that the OSE devices worked again, and eventually I was able to hook all the sensors back on being careful with the LEDs to avoid any unintentional short and the Robot seems to be working fine for a couple of months now.

I don’t know if this is helpful the reason I posted is I did not expect a short to the digital out (for the LED) would ever show up as a problem for the digital input of the OSE. The devices were plugged in at opposite ends of the digital port bus as well.

have you solved the problem yet?

JPearman I hope to see you at worlds, you’ve provided much help and inspiration to help others this year.

Kb

we have actually resolved the problem. My team decided to take off the 2nd LCD and we have not had the same problem yet.