Downloading firmware

I am changing from Easy C to Robot C. When downloading firmware from Robot C I plug in the cortex to the cpu with the power button off and a battery attached. When I turn the cortex power button on I have one controller that displays a green robot light as I turn on the cortex, and another that still shows a red robot light when I turn on the cortex.

I moved this thread for Kevin because nearly everyone at VEX who could answer this is on the way to Anaheim. I think the community can answer it.

Can you communicate with them? Were they both working with EasyC? Which version of EasyC did you have and what version of ROBOTC are you trying to change to? What does the software inspection window show?

There are some instructions on getting started with ROBOTC here.

http://www.robotc.net/wiki/Tutorials/Getting_Started/Getting_Started_with_the_VEX_CORTEX

The software inspection menu can be found here.

[ATTACH]7405[/ATTACH]

and should look like this (if you have ROBOTC V3.60 which I recommend).

[ATTACH]7406[/ATTACH]

Get back to us and we will see where to go next.
soft_inspect_1.jpg
soft_inspect_2.jpg

I now have a little time today to come back to this:-) When you check the joystick and cortex in software inspection can you check the joystick and cortex together like your screen shcws? When I check them seperately both show all up todate firmware, but the voltage never shows on the cortex with a battery that I know is fully charged. The joystick will not link up to other cortex controllers that I know are good.

I used the programming cable plugged into the back of the Joystick, the joystick was tethered to the cortex using the USB A-A cable, that’s why it shows both versions.

Was the joystick master firmware up to date?

Have you tried following the procedure for re-loading the master firmware into either the problem cortex or joystick?

So do I understand you have one good and one bad cortex? Also, one good joystick and one bad joystick? Were they working with EasyC?

I’m pairing the problem joystick up with a cortex that I know worked with a different joystick. The software inspection indicates both are up to date with good batteries. I link them up with a usb cable first and they connect with green lights, when I then switch to wireless and they link up initially and then the VEXnet light blinks red on both after 10 seconds or so.

Try a different VEXnet key on both cortex and/or joystick.