"Error: Model is disposed" when opening program

Posting for my old teammate:

Hello, I’m with team 95E and recently I went to competition with a code with an autonomous selector using the brain screen, autonomi, PID, odom, and simplistic drive controls. All were on different program files within the program project, connected with a hierarchy that connected separately to the main. There was main → auton selector → autonomous → PID → odom and main → driver control. This hierarchy worked flawlessly and I have used it since the beginning of the year, going to multiple competitions and having no issues with the code.

Then, after our 3rd comp, we came home and made some changes to our Autonomous and odom functions before shutting down like any other day. But now, after coming back the next day, I can no longer open the robot program and get the same error: Model is Disposed. I cannot see the code because it gives me this error after trying to open the project.

Specifically, when I try to open the project nothing happens (I’ve tried to give it time) and it just opens to the normal screen with no project opened and recently opened programs as options to click and open up. However, if I open another project first then try to open this project, the quick-menu on the left side stays the same as the originally opened project but the middle box that shows the actual program and its code goes blank. Nothing happens once again (I’ve given it time here too) but when I click on one of the quick menu options on the left from the old project file I receive this error:

I have older versions of the code that I can revert to, but I will lose a lot of progress with this issue if I am not able to open the code again. I have tried restarting the computer, reinstalling vexcode, opening it on other computers, and they all show the same symptoms and issues listed above. Please if you have any ideas on how to fix this issue or even just be able to grab the code from the project files so I can put it into a new project and restart, that would be wonderful. Thank you for your help!!

1 Like

all of you code should be in the files in the src and include folders.
It looks like the project definition file may be damaged. You can create a new project and copy the files over from the original, or zip up the whole project folder and send it to me and I will have a look to see what’s broken.


Sorry for the late response, but thank you for the help! The code was able to be recovered as you suggested