Help Needed Troubleshooting the Live Remote Practice Matches

So I have been searching the forums and haven’t found much yet related to the REC foundation’s Live Remote Practice Match system so here goes:

We finally set up a space in our school robotics shop to do remote events and we were very excited to try out the remote practice match system but we have run into a snag.

The Problem:
The webcam connects correctly but it seems like the problem is with the controller. It loads a screen to allow me to connect to the controller but then gets an error when I press connect. Digging a little bit deeper it looks like there’s an issue with the SerialPort. I’ve included a screenshot of the error as well as the developer console below:

An Error has Occurred - In Context with lobby and url Developer Console JS Error

Things I’ve Tried:

  1. Verified that the teams I am signing in with have been properly registered through robotevents
  2. Verified multiple times that “Experimental Web Platform Features” is enabled and Chrome was restarted.
  3. Verified that the firmware on the controller, brain, and receiver are all up-to-date. I literally watched my students perform the update.
  4. I tested the system on Chrome running on Linux and Windows 10 and in both cases encountered the same error at the same point.

Any ideas how to get this working? Are we the only ones with these problems? Why aren’t there more conversations and videos about people using this system for practice matches? If anyone could assist us that would be awesome!

3 Likes

did you enable experimental features for chrome ? web serial only works if that is enabled.
image

3 Likes

Yep. Did that (things I’ve tried #2). I don’t think it’d be able to even SEE the controller at all if experimental web features weren’t enabled. I can see that there’s a V5 controller to connect to but then it errors out when I press connect.

yes, sorry, that’s my fault for not reading your post fully.
let us do some digging at our end and get back to you.

4 Likes

any chance you are running chrome 86 ? looks like there may be an API change that google implemented.

1 Like

The version I’m using is 86.

In the settings it says:
Google Chrome is up to date
Version 86.0.4240.75 (Official Build) (64-bit)

We tested on our linux system using Chrome 84 instead of 86 and it works! Now just trying to have our web camera fit the frame properly… 7 feet by 7 feet still isn’t quite far enough distance.

RECF pushed a fix for the chrome 86 issue. It should be working now on your original system.

3 Likes