Motor randomly stops spinning

We have a clawbot for tower takeover, that has a motor that randomly stops after hitting the cube
We Tried:

  1. taking the arm and gear off the shaft of the motor so we can freely test the motor and see if the motor or other hardware was bad. It was not because it was spinning fine, so we know that our motors and motor controllers and hardware are good
  2. giving the arm manual power instead of using the joystick; it would still hit the cube, and the motors would stop running after the standoffs hit the cube, even if there was still a number in debugger windows
  3. Taking off the standoff arm and using a gear instead. We would hold the gear in place for a few seconds, to see if it was the circuit breaker in the cortex or motor controller to stop if the motor couldn’t turn when drawing too much current. However, when we let go the motors would continue to spin.

After troubleshooting steps, we still had the same issue of the standoffs hitting the cube, and not have power in the motor anymore.

Any help? Thx

This might be because the motor is burnt out (maybe idk is this cortex or v5?). Also you might want to recategorize this (@Railgunawesome @Xenon27 etc.)also @holbrook could help you (sorry I tag you on everything I dont know. You seem to like to help the community though)

us regulars can’t edit titles or recategorize topics, we haven’t been able to for quite some time now.

as for the issue here, have you tried switching motors? if hitting a motor causes it to stop working, there may be an internal issue inside the motor. if you switch motors, and the problem persists, it’s probably a mechanical issue. perhaps the friction in the system is too much for your motor to handle, or you have some other flaw in the actual mechanism causing this behavior. some pictures would be nice.

3 Likes

I know this might sound dumb, but does your code run the motor in reverse to open the claw?
(I spent 15 min 9nce trying to figure out why my code didnt work and turns out my motors weren’t plugged in

it is not burnt out, cuz it works fine when you take the claw arm and gear off so you can freely test the motor. it also works with the arm off, but just grabs the cube, waits 1 second, and then it randomly powers off.(i am giving manual power through debgger windows and using cortex) thx for help

Do you ha e a motor stop command after the function? A picture of your code would be useful

Is this vex iq or VRC?

This is vex EDR, not using joystick but with manual power from debugger windows. Same issue with joystick

I’ve had this problem many times. It maybe that your motor gets overheated or just runs too long. It happens all the time with our claw. If the motor runs for an extended period of time or gets too hot, an error message may not pop up and the motor will just cease to work till it reaches equilibrium (its starting state).

Here is a link to the video of the problem here
as you can see, we are manually powering the motors, it holds the cube fine, then all of a sudden the motor stops giving power. this still happened when we stopped the motor. any help plz

You are tripping the motor PTC, sending power of more than around 25 when the motor is stalled will cause the PTC to trip after some mount of time. Search the forum and you will find lots of discussion about this.

Lots of technical info here.

1 Like

thx for help, so the only solution is either to gear my claw for torque, or use less power?

I am having a problem and i need help. My robot would slow down and stop randomly I have changed the battery and it still continued, and the connection is still good

Is this issue separate from the op’s?
If it is i would recommend making a new thread, people on this forum tend to dislike when others bring back old threads lol

(personally idrc and will try and help anyways, if you send pics that would help us see your issue)

idk how to do that :disappointed_relieved:

@kakarot Drawing (1)

2 Likes