New Project won't create in cli

I am using the pros cli on manjaro arch linux. I ran “prosv5 conductor new-project ~/Documents/projectName” which has worked for me in the past, but this time it did not work. it returned the following error:

Updating pros-mainline… Done
Applying kernel@3.5.0 [####################################] 100%
Finished applying kernel@3.5.0 to /home/rosterkid05/Documents/test
Applying okapilib@4.2.0 [####################################] 100%
Finished applying okapilib@4.2.0 to /home/rosterkid05/Documents/test
New PROS Project was created:
PROS Project for v5 at: /home/rosterkid05/Documents/test (test)
Name Version Origin


kernel 3.5.0 pros-mainline
okapilib 4.2.0 pros-mainline
Building project…
Creating cold package with libc,libm,libpros,okapilib [ERRORS]
/bin/sh: line 1: arm-none-eabi-g++: command not found
make: *** [common.mk:229: bin/cold.package.elf] Error 127

Any answers or suggestions?

1 Like

It seems you don’t have the ARM toolchain installed or it’s not on your PATH.

The install link and install guide is available here: Installing on Linux — PROS for V5 3.5.0 documentation

Note the guide is for bash. If you are using another shell you’ll just need to replicate the instructions however for your specific shells config file. ie. For zsh you’d edit .zshrc

2 Likes

Well i used
“pamac install arm-none-eabi-newlib”
when i originally installed it, and the first couple of times it worked, it created the project fully and everything, what i don’t get is why it stopped working

Nevermind, i didn’t understand what you were saying at first, but what you said worked. Thanks

No worries Happy to help :slightly_smiling_face: