Problems with new vexOS 1.1.1 update

When we tried the new control system at a scrimmage, everything worked fine until driver control started. Once it started, it wouldn’t let me drive my robot at all until I restarted the code. nobody else had this problem; it only happened to me. I could restart the program in the period when auton is scored, but it is tedious, easy to forget, and it makes the robot let go of the neutral goal we grabbed in auton. What might I be doing wrong?

By “control system” do you mean updated vexos 1.1.1 ?

What was used to control the match ? A competition switch ? Tournament manager with legacy field control (cable into the center connector on your controller) ? or the new field control brain ?

When was this last working, what version of vexos did you have before ?
VEXcode, PROS or something else used for programming ?

Have you read this ?



we were using the new control system going to be used at worlds

we never had this issue until we connected to the new control system, and it only happens on the new control system. It worked with the previous control used at tournaments and the competition switch

there is only one thread running at a time

ok, are you Middle or High school ? What’s your team number ?

either way, at this stage the best thing will be to find either me (James) or one of other tech support engineers (perhaps Levi) at the beginning of the event, perhaps during inspection, and we will see what’s going on and hopefully sort it out for you. Make sure you bring your laptop and programmer if we need you to make changes to the code.

Did/can you try a different controller ? If the RJ45 legacy competition port is damaged this can happen, we have an update to the new control system which will detect this issue at worlds.


great, thanks for the help! I’m from the middle school team 15979K Annihilation Unit.

yes, we can. we use two controllers to drive, and we have a spare.

can’t wait to meet you there!