PROS Brain Downloading Error

Since it is impossible to currently download a program through the controllers due to the bug in PROS CLI-3.2.0, I tried to download programs directly to the brain but am unable to do so. The issue that we are running into is that once the download begins it appears to crash.
Screen Shot 2021-03-26 at 10.23.05 PM
The uploading just stays at zero and doesn’t time out and I am forced to disconnect or close the terminal. What is unique is that there are multiple different USB ports that show up. Two ending in 14101 and one ending with 14103. I only have one device connected so my guess is the reason for not being able to upload is due to having multiple USB ports showing up.
Screen Shot 2021-03-26 at 10.23.38 PM

Running on a MacBook Pro: Mid 2012 - MacOS: 10.15.7
Installed with both homebrew and manually and the issue still exists.
Pros CLI - 3.2.0

Any help that anyone can provide would be extremely helpful, we currently can’t install any programs.

The V5 is supposed to mount as two serial ports. One is for control/admin messaging (ie. program download) the other is for use by user code (ie. printf).
There should only be one pair ending in 1, /dev/tty.usbmodem14101 and /dev/cu.usbmodem14101 (the number depends on the physical port). So you are seeing two with /dev/cu… ending in 1 ?

have you tried reboot ?

@hotel. ^^^

2 Likes

Yes there are two ending in 1. When I select the one ending in 1 that is when it crashes. When I select the other one it returns an error message. I have tried rebooting everything multiple times and reinstalling the pros-cli.

what does “ls /dev/cu.usb*” show if you type that into the terminal ?
If it shows the same multiple devices, then it’s probably not a PROS issue. If it shows just one, then yes, something wrong with the PROS serial port enumeration.

3 Likes

What is the V5 VEXos version? PROS 3.2 only works with 1.0.13 which appears to have a change in the serial download format?

1 Like

There was not a change in download format. PROS had a bug where the reply to a status message was not being used quite correctly, PROS assumed the reply was always going to be a fixed length, the message format allows for variable length replies, so PROS aborted the download as it threw an exception when it received a reply that was not quite what it expected.

As far as I understand, the latest PROS cli is still backwards compatible with 1.0.12.

6 Likes

Here is the image for when I insert /dev/usb* into the treminal.Screen Shot 2021-03-28 at 12.36.03 PM The upload still crashes when I select one. When I disconnect the brain this is the error message I get:Screen Shot 2021-03-28 at 12.36.45 PM

yea, that wasn’t what I meant. Open a terminal window and type “ls -l /dev/cu.usb*”
you should see something like this. First two lines here are my V5.

james$ ls -l /dev/cu.usb*
crw-rw-rw-  1 root  wheel   21, 121 Mar 29 12:41 /dev/cu.usbmodem142111
crw-rw-rw-  1 root  wheel   21, 123 Mar 29 12:41 /dev/cu.usbmodem142113
crw-rw-rw-  1 root  wheel   21,  35 Mar 29 10:27 /dev/cu.usbserial-A403CSLP
crw-rw-rw-  1 root  wheel   21,  37 Mar 29 10:27 /dev/cu.usbserial-A403CUFA
2 Likes

When I try that I get ls: /dev/cu.usb*: No such file or directory

¯\_(ツ)_/¯

sure you typed it correctly, and the V5 was plugged in and turned on. I don’t see why there would be no devices at all. I just checked on a Mac running 10.15.7 and I see no issues with serial ports.

3 Likes

Are you using USB hub by any chance?

Also, you may have shaky connection at V5 micro usb port - be very careful with it.

Try different wires - the issue may be corrupted connection, when it tries to communicate at high speed.

Finally, you can try uploading initial monolith image from another computer and then do small incremental updates via wireless.

1 Like

I am not using a USB hub. I have tried different cables and am getting similar responses. Do I need to be in a pros project for this to work?

Also the issue is that I can’t upload via wireless due to the Pros Clis bug with vex os 1.0.13

Could the reason why this file not showing up be the reason why the download is crashing?

I am still trying to solve this error as we are getting ready for our state competition. Any new ideas on the issue? How would I go about reinstalling the V5 usb serial drivers?

Find or borrow another computer. Install and see if you’re striking the same issue.

1 Like

i still don’t know if this is a PROS issue, or just a Mac issue. Perhaps install VEXcode and see if that works.

The Mac doesn’t need serial drivers for the V5.

1 Like

By any chance, you don’t have multiple v5 brains plugged in right?

1 Like

Yes, I only have one V5 device plugged in and the issue is that it is crashing during the upload.