Robot Mesh cannot connect to my V5 robot brain

When I connect my robot to my computer using USB, Robot Mesh refuses to download a program, saying that “Error: Interface not connected or port not selected.
Please make sure your interface is connected and powered up.
To verify, open Options and make sure your interface shows up in the Ports dropdown.
Sometimes, restarting or reconnecting the interface can help fix this error.”

It used to work before, then suddenly stopped.

I use the Robot Mesh app installed onto my computer. I have already tried multiple robot brains, computers, and USB’s.

Someone mentioned something about an update, and when they came over to help us, it was working again. Then, we downloaded one program, and it worked, but it returned to the original problem after we tried it again.

If anybody has any ideas, please let me know.
Thanks!

Did the robot show up in the port selection drop down in Options?

NO. Nothing shows up.

Now even V5 Firmware Update Util cannot find the brain when it is connected with USB.

The next two things to try are a different USB cable and a different computer.

John: you are correct – I find some cable actually works after a lot of frustrations. I don’t have an explanation why the brain is so picky on cables, though.