[Temporally fixed, awaiting permanent solution]: PROS VSCode - cannot upload code to brain due to python permission error

Dear all,

It seems like there is some permission problems when uploading the code via the viscose extension /CLI in vsCode - any advice will be appreciated. Many thanks.

Operating System: Mac OS on Apple Silicon
Error Message:

......flywheel pros3 % pros upload
ERROR - pros.cli.main:main - [Errno 13] Permission denied: '/usr/local/Cellar/pros-cli/3.2.2/libexec/lib/python3.9/site-packages/idna-2.7-py3.9.egg-info/PKG-INFO'
  File "/usr/local/Cellar/pros-cli/3.2.2/libexec/lib/python3.9/site-packages/pkg_resources/__init__.py", line 1611, in _get
    with open(path, 'rb') as stream:
PermissionError: [Errno 13] Permission denied: '/usr/local/Cellar/pros-cli/3.2.2/libexec/lib/python3.9/site-packages/idna-2.7-py3.9.egg-info/PKG-INFO'
(base) USERNAME@NAMEOFMACBOOK flywheel pros3 % 

Semi solved:
still doesn’t work on the UI but by running sudo pros upload on the command line, it works for now. Any advice for a permanent fix is welcome. Many thanks.

I’ve had this same problem all year and I just solely use terminal now to build and upload