The V5 Controller doesn't turn on

The V5 Controller doesn’t turn on. We connect it to a computer through a micro USB cable to charge it but it doesn’t charge, but when we connect it to the V5 Brain it does turn on, only difference is that the screen on the controller flashes red intermittently. Then after we disconnect it it turns off and doesn’t turn on again. Does anyone know what could be the issue or how to fix it?

you could try to hard reset the controller by taking something like a low strength and sticking it into the middle hole on the back of the controller and holding the button down there for around 5-10 seconds.

1 Like

Does the usb cable work? We had a problem where the controller wasn’t charging but it ended up being that the usb we were using was broken and we didn’t realize.

Thanks, we already did that and it doesn’t turn on

We have tried with many cables but it still doesn’t work

It sounds like it could be a hardware fault. Maybe a faulty battery. @jpearman may be able to help.

1 Like

yes, sounds like a dead battery. How old is this controller ?


Thanks for your help, the controller is 3 years old