Trouble with connecting Vex IQ brain with a Dell Chromebook 3189 using Vex IQ coding Blocks

Let me say this first, I really like the new VEX IQ Codiing Blocks. It looks easier than the Graphical Robot C program that we are using now, but I am having trouble connecting my VEX IQ brain to my Dell Chromebook 3189. I have tried the using the program with my Microsoft labtop and it works perfectly. I have tried using different cords to connect the brain to the Chromebook. Am I overlooking something? I would really like to resolve this issue, since my students use Chromebook at school.

1 Like

have you downloaded the chrome os extension. i’m pretty sure Vexcode for chromebook wasn’t supposed to be realeased until later. It’s better if you program on a Windows computer so that the students can access their programs at the competition when there is no internet. Hopefully this helps.

Yes I downloaded the Chrome OS extension. So there will be another release later?

There is only one release of VEXcode IQ Blocks, which is available on the Chrome Web Store. No other additional extensions are required.

We’ve heard other reports of Dell Chromebooks having issues seeing the VEX IQ brain with VEXcode IQ Blocks and have hardware on the way to investigate - we have not been able to replicate the issue on other Chromebooks.

I hope to know more sometime next week. I’ll respond in this thread once I do.


Just an update… we got our Dell Chromebook in the office today and have been able to successfully replicate the issue of the Dell Chromebook not seeing either the IQ Brain or V5 Brain.

Our team will work on troubleshooting the issue and I’ll keep any pertinent updates in this thread.


Good news… We’ve identified the issue in how the Dell Chromebook is enumerating USB devices and feel confident we’ll be able to develop a fix for the issue in the next update in a few weeks.

Apparently these Dell Chromebooks behave differently than the other 10+ models we’ve tested during development so we never observed this issue.


Is there a download for a vexos to be used with Vexcode IQ blocks on a Chromebook? I have coach’s concerned that using the VEXCode IQ blocks on a Dell Chromebook at other schools may be buggy.

To our knowledge, we’ve resolved the issues with Dell Chromebooks back in late August.

The VEXos Utility does not currently support Chromebooks. We’re investigating ways to build that utility directly into VEXcode IQ Blocks.

Is the suggestion then to teams who use Chromebooks for VEXcode to do a firmware update on a PC prior to any competition?

Correct. You can update firmware via Windows or Mac before using on ChromeOS

@tfriez I am having the exact same nonconnection issues with ASUS C202S model chromebook. Would this happen to be one of the models tested? Because I nor my students can find a solution to the connection issue. Thanks so much for any help!