Ultrasonic Distance Sensor Issues

I am teaching the Carnegie course for the first time. We have 23 VEX IQ Super Kits. On about 5 of these brand new kits, the ultrasonic distance sensor says on the VEX brain that there is an object 2 inches away when there is nothing in front of it. We have used the VEX Utility to update and have updated the firmware on RobotC. We have tried different ports, unplugged all connection and rebooted, and switched them successfully ones that work. The sensors do not appear to have any damage whatsoever. I am very frustrated and dissatisfied with how quickly these have become unusable. Any feedback would greatly appreciated.

You said that they became unusable… did they work before?

1 Like

I’m unsure. They students who were using them struggled a while before they told me.

The ultrasonic sensor doesn’t sweep a 2D plane. It scans in the shape of a 3D cone with the vertex at the speaker. If possible, it would be nice to have some pictures to ensure that there is nothing in the way. Keep in mind that while the ultrasonic sensor is a very good sensor (out of experience), it still has some error which may make troubleshooting difficult.

1 Like

I have tried to just connect the sensor to the brain on an empty table top. It is still seeing 2 in. Switching the malfunctioning sensor to one that is working solves the problem, but out of 23 new robot kits, I have five that aren’t working.

If that’s the case, I recommend contacting vex support. In order to fix the problem, you would most likely have to manipulate internal electronics which is illegal. Vex may allow you to exchange the broken sensors for new ones (that hopefully do work).