V5 Controller Disconnects & Brain Crashes

So, my controller says (Robot link lost) why does that happen to my robot controller?I start drive for a few seconds then it disconnects can ya’ll help me figure it out.

1 Like

Are your VEXkeys connected securely and are your batteries charged? I had the same issue, and it was almost always the VEXkeys being disconnected. I would put electrical tape on your VEXkeys if you haven’t done so already to hold them in place.

1 Like

ok thank you, is the vex key a memory or hard drive you put in the controller ?If it is where can you get one that is cheap.

@gilmorkn472 was likely talking about cortex controllers, and it sounds like you have V5. V5 doesn’t have keys.

My only advice would be to make sure the connection from the brain to the antenna is good, and the antenna is mounted as high up and obstruction free as possible.

3 Likes

ok thanks but I just got another problem earlier my robots brain turns on but as soon as you drive it the brain goes crazy and has stripes all over it what can be the solution?

perhaps a faulty brain? does the screen bug out whenever you drive?

Perhaps a low charge battery? Bad/loose cable? White screen is predominantly caused by battery malfunctions or undercharging. This could be a variation on that.

Will other code run fine on the robot? Dies autonomous work? (Or auton skills?)

1 Like

yes it does a lot it stops working so I have to unplug the battery from the brain.

Then probably wonky battery connection. Try replacing batteries and battery cables

We have the issue too, it seems to be the brain crashes (the timer stops counting), and doesn’t respond, so you have to cycle with the battery.

Just to verify - all your hardware (especially batteries!) are on the most up-to-date firmware, correct?

1 Like

they are but still I fixed that and the brain keeps crashing I tried replacing the brain and connection but it still won’t work

Now it works but for some reason the robot automatically crashes whenever you drive it.

Can you post your code?

Unfortunately this sounds like a hardware issue with the brain, but it doesn’t hurt to check user code first.

how do you check the user code?

post your code so that people can see if there is an issue with the program.

1 Like

Did you write your own program?

Or, do you use the default joystick to motor number assignments that V5 has out of the box?

Are you writing in PROS because if you are you might want to clean your project. Cleaning the project will delete your cache (all previously compile files, may be interfering with connections between files). You might also want to try deleting your bin folder as a clean version of the folder will be in your project as soon as you restart PROS (this is specifically for PROS). Our robot had a similar problem at worlds and we had to talk to tech support and then one of the members of the PROS dev team.

That is only to fix the user code not working, such as a segfault.
All cleaning does is make sure all the separate files are talking about the same shared objects.
Its definitely a good thing to do when troubleshooting segfault or strange behavior, but I don’t think this is his issue.

I think the OP has an issue with the actual brain crashing, not just the code crashing. In this case, its unlikely it has anything to do with the code.
We need more information, but it’s possible there is something wrong with the brain, such as it crashes as soon as it tries to power a motor.

1 Like