V5 Motor Issue

Hi all,
I had a very strange issue in a competition today. This is my 4th tournament with this exact robot, and this is the first time I have had issues with it. 2 of my V5 motors died in a rather peculiar way. Before 2 of my matches, (one of which was unfortunately finals) 2 motors randomly died despite passing a pre-match “systems check” to make sure everything works. They no longer move. They are not seized up, they spin freely. They just emit a high-pitched beeping noise when power is applied. I took apart one of my motors to verify that it was not anything mechanical, and when I isolated the motor/circuit board the problem persisted. I connected a 9V battery to the motor and the motor spun properly. The motors both came off of my drive and were not experiencing any abnormal stress. I am quite upset that this happened because (aside from costing me the tournament, but I can get over that) I can not be sure that this problem will not happen again. I want to figure out exactly what happened so that I can make sure none of my motors ever do this again.

I think it is worth noting that I am 95% sure that both motors were connected to the same port and wire on the V5 brain. Anyone have any advice or has experienced a similar issue?

Thanks,
Brian

1 Like

Yes-- our was caused by conflicting motor powers being sent to the motors. The compiler in PROS cannot catch issues like this, so it took a while to manually debug it. We think that if you use the chassisController from OKAPI and the robot is in the middle of a movement when auto ends, then for some reason it continues to try sending power to the motors once op control starts. That conflicts with the input from the joysticks and the motor buzzes since its trying to do two different things at once. From the wording of your post, it doesn’t seem like all your drive motors were affected, so you might be having a different problem.

TFW you lose finals

Makes sense. I’m a bit hesitant to believe this because it wasn’t all my motors, I haven’t had this issue before, and I haven’t changed my auton algorithms.

feelsbadman

I know @jpearman 's department is more software, but do you have any idea what it could be?

not much information to go on, but it sounds like another case of this.
https://vexforum.com/t/v5-brain-ports-break-continually/49750/1
ports on both V5 brain and motors have been seen to be affected.

Need to know, do the motors work at all now on any brain ports ? What does the motor smart port led show ?

The motors do not work on any port. The LED is solid red.

Try adding a command to the beginning of your driver control loop to manually stop autonomous. It can’t hurt and if it helps then you’ll know what the original problem was :stuck_out_tongue:

Hello Brian,

We have the same problem and came to the conclusion that it has to do something with the circuit board. We sent an email to vex and are waiting if they are available to give us the schematics for the V5 motor circuit board. If we get an email with the schematic we can address the problem further but at the moment there is no solution to the problem that worked for us.