VEX Assembler Public Beta available!

VEX Assembler is a brand new, free design package made specifically for the VEX IQ robotics platform. VEX Assembler, powered by Autodesk® 123D®, brings the modern principles of computer-aided design (CAD) into an easy-to-use drag-and-drop interface.

  • Powered by industry-proven Autodesk 123D design software
  • Drag-and-drop, snap-together interface
  • No previous CAD experience necessary; perfect for budding engineers
  • Preloaded with over 110 unique VEX IQ parts, including field elements from the 2013-2014 VEX IQ Challenge, VEX Add It Up
  • Includes a pre-made model of the Clawbot IQ
  • Multiple team members can work independently and share their designs digitally without being limited by physical kits
Sign up for the public beta and get your FREE copy today! Visit for details on how to register.

Could regular VEX parts be used with VEX Assembler as well

Currently, only VEX IQ parts are listed in VEX Assembler.

Is there an instruction book or documentation on how to use the General User Interface (GUI)?


Is anyone else having troubles running Vex Assembler on Windows 8? I find that it crashes when you try to connect parts.

Looks like I’ll be finding that out as well, my computer is running Windows 8. I’ll let you know one way or another as soon as I am able.

Windows 8 is not currently officially supported by VEX Assembler, due to limitations of the Autodesk 123D platform it is built upon. The platform team is working hard on compatibility fixes, which could theoretically lead to a rebuilt version of VEX Assembler, but at this time we do not have a timeline estimate for those updates.

How do I open the Clawbot robot in VEX Assembler? I don’t find any *.vex files anywhere after I installed the program.

Timdreamer -

In the zip file you receive when downloading VEX Assembler, there should be an installer (.exe) and a folder named “Clawbot” with various components. Double-check where you extracted the zip file (for example, a “Downloads” folder) for that “Clawbot” folder.

Excellent!! Thank you very much, Grant!!

Vex Assembler crashes after launching it in both Vista and Windows 7. We get an error message saying that it has stopped working. Is anyone else having this problem? Anyone know a solution?

I am having the same problem with the message “stopped working”. I ran it as Administrator as suggested. When I tried to open the supplied file “Assembly” with it, I received the following error message & it again closed:

NVOGLDC invisible: VEX Assembler.exe - Application Error

The instruction at 0x5f5e2dd0 referenced memory at 0x1b840004. The memory could not be written.
Click on OK to terminate the program
Click on CANCEL to debug the program

I have tried this on 2 different computers, one running Vista & the other Windows 7. How do you make this work?

Grandpa3 - Please see this thread for some common troubleshooting tips and let us know if they help.

Grant, Thanks for your reply. I’ve tried to understand your “tips” & try them. First, I’m unable to send a “screenshot” of my computer properties. It doesn’t allow a copy/paste function. On my laptop, HP Pavilion dv9700 Notebook PC, I’m running Windows Vista Home Premium with Service Pack 2. Its a 32 bit OS with an Intel Core 2 Duo CPU T8100 @ 2.10GHz 2.10 GHz with 4.00 GB of RAM. The Windows Experience Index Rating is 4.8. I have a NVIDIA GeForce 8600M GS graphics card. I’m not sure about tweeking things in my system which runs everything else just fine in order to make this one program perform properly. What was this program developed for & tested on? My system certainly seems powerful enough to run most applications so based on so many other’s having similar troubles I suggest someone fixes the bugs in this program to make it compatible with all of our current systems. This becomes quite frustrating when we consumers buy products from VEX to discover we are in actuality beta testing for them for the defects. I’ve been through several “firmware updates” with the VEX IQ & see many more to come due to incompatibility issues with ROBOTC & its own hardware. I was pleased with the VEX Cortex products previously but the IQ seems a rushed debacle. I don’t mean to criticize but I would really like to see these things work without so much user fixing. What more can I supply that might help. Thank you for your assistance.

Grandpa3, I apologize for your difficulty. You make a couple of points here that I’d like to address individually.

  • Your system does appear to meet the minimum requirements.

  • Between internal testing and our two month public beta period, development builds of VEX Assembler interfaced with a wide variety of different system configurations, computer types, and work styles. The public beta was especially useful in identifying and fixing a number of compatibility issues.

  • The fixes described in the other thread, with the exception of disabling GPU switching, apply only to the Assembler installation and should not have adverse effects on anything else in your system. GPU switching is a feature designed to improve laptop battery life by forcing lower graphics; for graphics-intensive programs like VEX Assembler or other CAD packages, you can see why this would cause incompatibility.

  • VEX is extremely appreciative of the enthusiasm with which you and others are diving into the new VEX IQ products so quickly. Early adoption is an important stage of any new product or technology, and things like firmware updates or service packs are crucial to ensuring the best user experience possible. The VEX Cortex has gone through a number of firmware updates, smartphones apply updates over the air, etc. As such, the IQ firmware update process is designed to be relatively painless; you can register for email notifications to know when an update is available, and the new firmware is applied in seconds. You’re correct: there will be more updates based on user feedback and internal testing, so we’ve built up the infrastructure to support that.

If you are having other difficulties with the VEX IQ products you’ve purchased, remember that you can contact at any time for additional assistance.

I installed the Vex Assembler to my Windows 7 PC. To my dismay, the editor is so lacking of important functions to manipulate the parts. Like for e.g. the parts cannot be move or slide. Just like the finger of the spider as seen at this video

In the video, the instructor point the mouse on the finger, and the finger slides or move without detaching from the body. Maybe I don’t know which command to use but I read all the commands available at Vex Assembler editor, but i can’t find the command to slide or move the parts without detaching from the main body part.

From my perspective, the editor isn’t easy for users to use. How much more if students use it. I hope they should do more improvement on it.

Did you have a look at LDraw system (see this thread):
I won’t say that the system is perfect, but it has been used by many people with astounding results!

Thanks Philo