Vex IQ battery Not charging blinking red light

Hi so we have a vex iq battery that was left in the brain by the previous owner. When connected to the charger it blinks red. We have tried to manually charge the battery by connecting it to a motor and spinning it. That gets it to go to a solid red and then after about 10 minutes it will start blinking red again, Looking for ideas or if this should just be replaced


I’m in vrc now but when I had problems like that I put the battery on the brain and turned it on and immediately took it of and put it pack on like 5 times really fast and that fixed it. If this doesn’t work then idk what is wrong

Yeah I have tried that a few times seems like after about 4 - 5 minutes on the charger it changes back to blinking

I tried charging it for like 3 hours off and on and finally after pulling it out like you said a few times really quick and putting it back in it started to charge.
Thank you

The times I’ve had the red blinking light, it’s been when the battery pack is very warm. I would take it off the charger for 10-15, and then put it back on, and that would usually resolve the issue.

Bad idea,

Please use this knowledge base article to fix this @michael_stes -