Vex IQ Brain is not recognizing the Controller

Hello there,

I am having an issue with my brain being able to recognize the controller. I have tried below options and the controller is still not being recognized. I am using a mac by the way.

Before trying out these options I made sure to verify that the smart radios were plugged in all the way and the cables were plugged in snug.

Option 1 - Connect all devices to the brain and turn on vex os utility software. All the motors are recognized and the controller is not.

Option 2 - Unplug all devices and just have the controller connected to the brain. The controller was not recognized at this point.

Option 3 - Firmware update was performed to all devices with the exception of the controller since it is not being recognized. How do I roll back to a different version of the firmware on a mac?

I really appreciate any pointers anyone can give me in this regard. I will be calling vex support tomorrow to see if there is anything else that I can try.

Thanks in advance.

You could try a different network cable between the brain and the controller.

Wow, I’d had posted another thread on the same issue earlier today.

Are you using the RJ45 tether cable that comes with the robot kit? So, the controller doesn’t work when it’s plugged in via the tether cable? The problem I had was that the controller wasn’t working/pairing in radio mode. It worked fine when tethered. I think mine is due to a bad radio on the controller.

Are you seeing the tether icon (like a little plug) in the top right of the brain screen when the controller is tethered?

Unfortunately I do not have a spare cable to try this option. I have a tournament coming up and our robot is not functional without the controller.

I will try to find a new cable to see if that fixes the issue. Thanks for taking time to respond to my post.

Yes I am using the same RJ45 tether cable that comes with the kit. The brain is not recognizing the controller even with the cable plugged in.

I will check out the details of your post next to see if I missed anything. Thanks for responding to my post.

No I do not see the tether icon when the controller is tethered.

It is a normal Ethernet network cable, if you have one around you can try that also.

Got it, should have one of those around. I will try it out.

Its possible that during this process my brain is updated to 2.1.3 and the controller firmware is on a previous version. I am using a mac and have the VexOS utility installed. I noticed on one of the pages on the web that the windows version provides a different interface and allows for each component to be updated separately.

Is this possible with the mac version of the VexOS utility?

I think you’d see the tether icon either way. So, bad brain connector, bad ethernet cable or bad controller connector seem like possibilities.
Do you have other brains/controllers/cables so you can find out which by process of elimination?

Thank you all for your replies.

I was able to get this issue resolved and the problem was isolated to a bad controller. I was under warranty (less than 1 year) and the vex support team replaced the controller. I called in Vex support on Tuesday and the new controller reached me on Saturday.

The new controller is working well so far.

the little radio receiver may not be good u may have 2 take it out and put it back in