Vex Via IPhone 13

Just update my phone and Vex Via is not loading any tournaments or working at all. All pages are blank. Anyone know how to fix this? I am running the latest iso 15.2.1 and have tried all the tricks try and get the app working.

Vex Via is not the issue, I have a Samsung S21+ and it works perfectly fine, my mom has a Iphone 13, and Vex Via works on her phone so probably you should delete the app and reinstall it. Should work>…

I have deleted and reinstalled it 3x. Still does not work. Thank you so much for your reply. Super frustrating.

Try switching from wi-fi to cellular and vice versa.

Maybe try restarting your phone… always when things act weird that seems to work lol

Thank you both for the suggestions of the wire and restarting my phone. Tried both still nothing. Maybe I need to be at a tournament and try the app there. It’s the only other thing I could think of but in reality it shouldn’t matter, you’d think.

Looking at the reviews, this appears to be a common problem and seems like it may have existed for over 10 years


It is likely a software or network back-end bug on the developers side. It sucks though because it seems like it is incredibly difficult to reproduce. May be a cool idea to have VEX apps have a log output, so that you may paste or download the app log and post it here for further details about this situation which may have existed for almost a decade.

1 Like