Vex Workcell Inconsistency

Has anyone else had problems with the disk pick up/drop off in Labs 7/8? Our workcell is all over the place. We originally used manual move to get the coordinates, but realized that was highly inconsistent. So we used Arm Jogging to get the coordinates and that worked better but still every time the program is run, the arm goes to a different point than it did previously and it isn’t always the same point it will be one place one time and a completely different place the next. Not far off a centimeter or two, but always off. Any help would be appreciated. I am getting very frustrated and losing class time because we can’t get it to do what it is supposed to do.


I’m having a similar issue in lab 11/10/9 (I built everything at once) where my arm’s inconsistent. Can you share your code? I’d like to compare it to what I’m doing.

Starting this off by saying this is not supposed to target anyone, or make anyone feel bad, but before other members pile on, please follow this -, post the information here, and then use it on all other posts you make were you need help, this will induce less stress for you and get you a faster response.

Good Luck!


Arm Mastering is failing. Is there an easy way to get the potentiometers on the workcell to pass? Motor 2 for example can’t be taken off without taking the top arm all the way off.

Hi @jspurr!
With the disk pick up/drop off, I would suggest adding in the code a block that sets the electromagnet’s power to 100%, adding in a wait statement after the drop code then raising the arm in the z direction followed by another wait statement. Also, the electromagnet should have a plastic sticker on it while the disks shouldn’t. If they both have the plastic sticker on them, there might be issues with disk pick up/drop off. I have attached a picture showing an example of the coding for picking up and dropping the disks.
With regards to the arm moving to a different point at the start of the code each time, one thing that can minimize this change is by placing the mastering jig into the arm before each trial to ensure the arm is in relatively the same position each time.


Hey everyone! I am having an issue with the workcell making a shaking/twitching movement while running a program to draw something with a marker. This program worked perfectly previously but now it does not work. I use the workcell in my class and students build it. One set of students built the workcell and ran the drawing program no problem. Once the labs were completed, they dismantled the workcell and a new set of students rebuilt it. The second pair of students are having the shaking/twitching issue. They built the workcell the same way. We replaced a couple of potentiometers that weren’t working with new ones but can find no issue that might be causing the problem. If anyone can provide some insight, I would appreciate it.

I had a similar issue with motor 4 and the way i fixed it was to remove the axel holding the arm on and rerunning the arm install program

Thank you! We will give that a try.

My team is having this problem with work cell lab 7. Are there anymore suggestions.

Did you get lab 7 to work?

This happened to me last year and it turned out I was using the wrong motors for the arm. Check your motors and make sure you are using the correct motors. You get 2 types of motors:

1 Like


I am having the same issue with accuracy. I am also having the mastering get off every time we run the arm. We are spending about 10 minutes a class on the labs and 40 minutes on mastering and remastering. I think the position of the pots are the issue. I don’t know why vex didn’t use the optical encoders, which is much more realistic to an actual industrial robot arm.

Were there ever any magical solutions to any of the issues above? I am just starting with Workcells in my classroom, and we have spent an embarrassing amount of time trying to master these things. I’m beginning to wonder if I didn’t just waste a lot of money buying 6 of these kits.

Hi again @brianG, there are many different issues listed above, each with their own respective answer. From your previous forum post, I have laid out a couple solutions you can explore in order to iron out the mastering process with your Workcell and get your Arm to be more accurate. Please let me know if you have any questions regarding these steps.


Yes, and I am trying to find information using another route. I had already tried the things you listed, and I thought I might trying another route. I didn’t realize that I needed your permission to post in another thread.

1 Like

Hi, I am also having this problem. I’ve ensured screws aren’t over tightend, connections are correct, and lubricated the flywheel. I often have to remaster every time I run a program, and it eventually falls out of acceptal bounds, needing to run the Arm Install program again. Is it possible that the potentiometers are bad? These are under a year old, so I hope not.