VexCode Block - File Download Error

I get an error when trying to down the program to the V5 brain. We are running Mac OS 10.14.15. All firmware updates have been done. The error message says, “An error has occurred. Your program failed to download. Please try again.”

02%20AM

Could you post your code in full? Sometimes this message is caused by an error in your code causing compilation to fail.

Also, make sure there are no other apps open that try to talk to the v5 brain (firmware updater, VCS/VEXcode text, etc.)

1 Like

Thanks for the reply. There are no other apps open. This program download to the brain the first few times we tried testing code. Then this errors came up. Here is a screenshot of all the code in the file. 41%20PM

Try putting all the if statements under a single when started statement.

2 Likes

Yeah, this probably wouldn’t cause it to not compile but that code probably doesn’t do what you want it to do. If, for example, you press and hold down only the up button on the controller, then there is one piece of code constantly telling motor RightFront to spin at 100%, and another piece of code constantly telling RightFront to stop, which is not really a useful combination of commands.

To continue tracking down your original problem, I don’t immediately notice anything in your code that should cause it to not compile (but I could have missed something). If the failure to download did not coincide with any changes to your code, then the problem likely lies elsewhere.

Let’s try some hardware/software debugging, I suggest you try as many of the following as possible. Depending on which of these work and which don’t, that will give some more information regarding the source of your problems.

  • Downloading the same program to a different brain
  • Downloading a different program (the simplest one you can come up with) to the same brain
  • Downloading the same program to the same brain using a different USB cable
  • Downloading the same program to the same brain using the same USB cable on a different USB port
  • Downloading the same program to the same brain using the same USB cable on a different computer
1 Like

Thanks for the suggestions but those didn’t fix the issue.

  1. Got the same error when I tried to download to a different brain
  2. I can create a simple program and it will download to the brain
  3. Same error message
  4. Same error message
  5. Same error message

Any other ideas?

The new update (coming today, actually) will resolve a lot of these issues.

Most of the time the issue is related to a compiler/code problem where the software allowed you to do something you shouldn’t have. Something as simple as a variable declared twice with the same name will generate that cryptic error message. Here’s what the NEW message will show if the duplicate variable issue exists:

04%20AM

2 Likes

OK, that definitely sounds like it’s a compilation error in your code - could you post the .v5blocks file in this thread? (or feel free to PM it to me if you’d rather not post it publicly)

I went to save the file for upload (doing a save as) and the file downloaded to the brain. I didn’t change any of the code. When I first did a save as that was not the case. As a new user, I’m not allowed to upload attachments.

Thanks, I will look for the update today.

im receiving the same type of error but it says
make’ is not recognized as an internal or external command,
operable program or batch file.
make process closed with exit code : 1
image

If you restart the application does it resolve the error? We found a bug in the latest version that if you do many downloads in a single session (30+), the Path variable runs out of space. This issue has been resolved in the next update.

If restarting does not resolve the error, then it may be a permissions issue for the “Temp” environment variable that the compiler (make) uses - basically “make” doesn’t have access to generate all of the temporary files needed to compiler the program to send to the robot. Is this a school managed machine? Has it worked in the past?