VEXcode IQ Blocks - iPad won't connect

Our iPads will not connect consistently to the robot brains. Here and there, it will connect for a moment, but I cannot figure out any pattern as to when they connect and when they won’t. IT has removed all firewall restrictions but this has not solved the problem. Any advice? Thank you.

First, make sure you follow the steps on how to connect:

Next, make sure that all of your firmware is updated on your VEX IQ Brains:

Lastly, make sure that your VEX IQ Controller is turned off while trying to wirelessly download. Also make sure that the Smart Radio is fully plugged into your VEX IQ Brain.

3 Likes

Hey! I have the same issue as stated in the first post, but I cannot get it to connect at all. I’ve run through the steps in the help post, and my firmware is updated. The Blocks program just sits and spins, waiting for a connection that never arrives. Any thoughts?

We are using iPads running iOS 13.3. iQ Blocks is updated to the latest version. We have not been successful in connecting our iPad to the VEX iQ Brain. Firmware has been updated on the Brain, controller is off.

Any other suggestions?

Make sure you enable radio data as well:

1 Like

We have the same issue here. We’ve updated our firmware on the brain, motors, sensors and controller. We are running v.2.1.5.

In the directions for connecting the iPad we are instructed to go to settings/system info and make sure radio data is on. I don’t have this option- we see Voltage, Radio Data (0%), Radio Losses and then the brain ID.

This robot connects to the controller wirelessly using the smart radios with no problem. It will not connect to our classroom iPad Air 2 using VexBlocks software. We enter the five digit radio ID for the brain into the software and the software hangs - we get the message “Connecting to: (brain ID)” and it never connects. We’ve tried power cycling the brain with no result.

Has anyone else encountered this? Any solutions?

Thanks!

Have you got black 2.4GHz radios or blue smart radios?
With the black radios you won’t see the radio data option I don’t think because they don’t support bluetooth.