Vexcode pro on Mac OS Monterey

Hello, I updated my mac to mac OS Monterey a week ago but now Vexcode pro is crashing every time I run it. I tried a reinstall but it keeps crashing. Is vexcode pro generally bad on mac os?

1 Like

The VEXcode download page has two different downloads for VEXcode Pro V5 on macOS – did you download the version labelled “10.13 - 10.15” or the version labelled “Big Sur (beta)”?

No, generally it works as advertised.

I downloaded the big sur one because Monterey is after big sur.

1 Like

I just upgraded my Mac to a new one. Now as I write this I am testing how this working and I it does open correctly. Some sub program did crash at first but when reopened it hasn’t crash yet. I can’t connect and download to a brain right now but my code does compile with no crashes.

Hey @EliteBabby I’m from the VEXcode dev team. We were testing this on our end on Monterey on Intel and M1 machines and we were able to download and run the app fine. What you can try is a complete fresh install of the application.

Delete the application from the Applications folder, and then delete this folder in finder /Users/{userName}/Library/Application Support/VEXcode Pro V5 then try to install the Big Sur beta again and launch it to see if that helps.




I tried that but I still have the same issue… I also tried restarting the laptop a few times too.

Is there anything else that can cause this error to happen?

I tried doing a clean install of vex code even after deleting all the files affiliated with vexcode but the same issue persists. I also reinstalled Monterey and even tried it on parallels too. However, on parallels, the program runs but fails to transfer the program to the brain and gets an error at 5%. It would be great if this can be fixed on either mac OS Monterey or parallels.

This is really strange it is persisting through an OS reinstall.

Could you give me a bit more info about the machine you are running on? Like is it an Intel machine or M1? Everything I’d want to know would be in the overview tab in the About This Mac window.

Another thing you can try, is installing VEXcode V5 Blocks and seeing if you have the same issue. They are similar enough applications that if one runs then they both should. So seeing if that runs can help narrow down any issues.

1 Like

Hello @tbobik, I have an intel MacBook pro from 2019. Screen Shot 2021-11-10 at 3.46.20 PM

I did try installing VEXcode V5 blocks and it ran perfectly… To be specific, when I run VEXcode pro, everything looks normal except the whole window is gray then crashes in 1.5 seconds.

I have had the opportunity to test this out. My code downloads correctly to the brain using a micro usb plugged into the Brian directly. I am on OS Monterey and I have the M1Pro chip.

I’m going to try to downgrade to big sur and see what happens…

Edit: Everything seems to be working fine after I downgraded to big sur and restored from a time machine backup.

Continuing the discussion from Vexcode pro on Mac OS Monterey:

Mine is still crashing on startup on Monterey (12.0.1) immediately on startup. A blank window opens and within a second, the app crashes and the window goes away. This is on an intel iMac Pro with lots of resources. Any news about how to make it work? It also fails on my M1 2019 Intel MacBook also running Monterey.

Thanks for you help!


I am also having the same issue on the same OS, why hasn’t this been addressed yet?

1 Like

I have an intel 2015 MacBook air running macOS 12.2 and both VexCode V5 and Pro V5 work fine for me. I used the Big Sur (beta) Download link and it works without a hitch for me.

Are there any updates @tbobik? Seeing that people still have this issue, I am too afraid to upgrade my mac os.

That’s weird, I have wiped all vex from my laptop and tried to re-download the Big Sur (beta) and I still can’t even open the application. Maybe some other app is preventing it, I looked at the stack trace on my terminal run and got something like this,

abort /Applications/VEXcode\ Pro\

As well as a deprecation warning.

@EliteBabby @bardsam So, we’ve played around with the current Big Sur Beta and non-Beta builds on a few different macOS machines and noticed that the non-Big Sur Beta version is working on Monterey and Big Sur machines.

So, could you guys try the non-Big Sur Beta?

We’ve tested it on M1 and Intel Big Sur machines, and an M1 Monterey machine and weren’t seeing crashes. I would suggest updating to the most recent version of Big Sur/Monterey and clearing the app data like I suggested before.

Hey, that sounds great! I’ll update and try out new vexcode pro after states just in case because I don’t have time to downgrade my mac os if it doesn’t work.

By Big Sur Beta I meant for VEXcode Pro! Not the macOS. I was just saying if you downloaded the non-Big Sur Beta VEXcode Pro that might work.

Sorry for the confusion!