Battery Full and Dying

Our battery is full when we take it off the charger and within 5 seconds it dies, happens with multiple batteries

1 Like

possible reasons:

  • bad batteries
  • bad charger
  • bad brain
  • bad battery port on brain
  • bad battery cable

try to eliminate the possibilities by testing multiple devices for these possible problems. for example, you say it’s happening with multiple batteries, so that decreases the odds that it’s the batteries which are the issue, seeing as it isn’t likely for all them to fail. however, if you can find a battery that does work fine and doesn’t die instantly, then perhaps it is the batteries that are the issue.

10 Likes

Assuming V5, since that’s the forum you are in. What does the battery display look like from the V5 panel with it plugged into the charger and off the charger?

1 Like

Sorry it took a while to post the vid. It wasn’t working but here is it. Yes I am on the same team.

I would try resetting the battery…

We did thst like ten times. Trust me

I have the same issue with my batteries. I presume it’s due to bad chargers but I only have one charger at my house so I’m kind of stuck. If you find a solution @Calvin_Thrasher can you tell me how you fixed it?

Yah. But I have no clue so I guess we are just gonna have to hang tight on this one.

It doesn’t look like those batteries are dead –– they are malfunctioning on a full charge. Make sure all your devices are updated to the latest v5 firmware. Sometimes letting the batteries sit overnight or a few days has helped me with this kind of bug.

If it’s a consistent issue across multiple batteries, then the charger is probably bad and caused multiple short circuits. Nothing is off the table.

3 Likes

Well all of our stuff is updated. And these batteries just sat for like a straight week. They have been like this for a while now but we can’t seem to figure it out. And we have many different batteries with different problems but we forgot to put those in the videos

Connect the battery to the brain and run the V5 battery Medic using these instructions: https://kb.vex.com/hc/en-us/articles/360035590212-Battery-Medic-Electronics

7 Likes

@jpearman. Sorry if I am disturbing you but do you know anything about the batteries and how to diagnose the problem?

yea, I know too much about the batteries.

The first thing is, do not reset the battery, it loses information when you do that about state of charge.

charge the battery for at least an hour.

run the battery medic as @sazrocks suggests and post screen shot of the result here.

14 Likes

Ok I will do that tomorrow. Thank you.

Worked for me. I’m still confused on why it happened in the first place.

@9935E does the medic fix the battery or is it just a thing to diagnose the problem

I have 13 batteries that do this. To many undervolts. VEX wont tell me whats wrong with them. So im out $715

Have you run the battery medic ? What does it show ?

How long do the batteries last ? Undervolt protection may happen, it doesn’t necessarily mean the battery is bad, just you were potentially pulling a lot of power as the battery was depleted.

5 Likes

Ya, they all have undervolt errors. Between 8-159. they just give up at random times, sometimes while the robot isnt even moving and the battery is at like 70-40%